Papilio Pro malfunction? Retrocade and Arcade Megawing both not working


Recommended Posts


I just received a Papilio Pro from seedstudio(china) and the two megawings (retrocade synth and arcade) from a german distributor about two weeks ago, and the megawings both don't work.

I post this in the Papilio Pro board to find out, if the PP is broken, or both MegaWings are broken (might also be, they look a bit used)

I tried the retrocade synth first with papilio loader 2.8:

- writing to SPI flash works, verifying also, but the time it takes seems to vary a lot -> verifying was OK every time I tried

- writing to FPGA also seems to work fine, I also switched the loader to expert mode like suggested in another thread

- no reaction to MIDI input (double checkt the cable and keyboard I used)

- at one point, a demo started to play ("welcome to re-re-retrocade" and then some music), but it sounded really glitchy (first some voices sounded like they skipped a few notes, but it got worse to the point that hardly any notes were played)

- most times the display stayed blank, once I got to the space invader menu where i could select midi channel etc. with the joystick, but still no reaction to the keyboard

- when I started the programming operation, the space invader thing showed on the display during the programming process, but disappeared when the programming was done


Then I also tried the Arcade MegaWing with the latest version of the software, loaded a game, but my VGA monitor didn't display anything. I didn't test this one a lot though (if it would have worked I could have been sure the Retrocade Wing was malfunctioning).

I use Win10 and enabled the Testmode to install the unsigned drivers before I installed both MegaWing's software.

Question: Is there an easy way to verify that the Papilio pro board is the broken one? Some diagnostic tool or something? I don't really want to send it back to china before I know for sure which board is damaged.

Would be happy about any suggestions what else I could try.


Thanks in advance,


Link to comment
Share on other sites

Hello Henrik,

Sorry you are having problems, lets work through them and see if we can figure out if anything is broken. If anything is not working as it should we will make sure that you get a working board, whether from Seeed or us directly.

For the Papilio Pro board itself, this is a good place to get started:

There is a quick start bit file that can be downloaded here:

You should see every other pin toggle and you should see an ASCII table output on the serial port. 

For the very latest code for the RetroCade and Arcade MegaWings please download the DesignLab IDE here:

There is an example project for the RetroCade that includes the latest bit file and the latest source code for the RetroCade. There is also an example project for the Arcade Megawing that will output video and music so that you can verify that the hardware works. You will find both projects when you open DesignLab and see the initial table of contents page, just use find to get to them. The source code for the Papilio Pro Quickstart can also be found here...

Hope this helps and keep us posted.


Link to comment
Share on other sites

Hi Jack,

thanks for the quick response. I tried the bin file you supplied, the board is powered by USB now, and all the pins from port A,B,C that I tried are constantly at 3.3V.

The oscillator itself seems to be running, the messy signal is just because I dont have a proper scope available atm.

About the ASCII-table: Which serial port do you mean? The SPI close to the USB controller? Or is there a UART over USB available over hterm etc?

Edit: the loader's last message after programming is:

Could not access USB device 0403:6010.


Best Regards,





Link to comment
Share on other sites


There is a dual channel USB chip on the Papilio board. The first channel is used to program the FPGA over JTAG and the second channel is used for UART communications. You should see the ASCII table output on the second channel... Here are some guides to show how it works: - Go to the very end to see how to use Putty to see the ASCII table.

Designlab has built in USB communications.

The screenprint that you included above looks like it loaded the quickstart bit file just fine. Its is unusual to see that last bit, but it looks like it is working overall. 

Please be sure to power the device using the USB port and not the external power supply. There shouldn't be any need to power from the external power supply because all of the examples work fine with the power supplied by the USB port. The external power supply was included just in case there was ever a project that needed more then 500mA of power. There has never been a Papilio project that has needed that much power so it is highly recommended to not use the external power connector. If you do use it, you want to avoid using a voltage much higher then 6.5V. Higher then that causes the voltage regulators to generate too much heat.


Link to comment
Share on other sites

Okay now I see the ascii table on com7 and also every even pin toggles (didn't test everyone though). The com ports use the standard FTDI driver, not a specific papilio serial driver, on my machine, might that be causing problems? I guess the drivers were already there because I used FDTI UART cables on this machine before.

The program seems to only run once I restart the papilio board after programming (takes about 3 seconds to start then).

I also tried the same with the retrocade wing and firmware, but even after restarting it doesn't show any lifesign.



Link to comment
Share on other sites

Hi Felix,

thanks! I tried ROMVault, it failed over the USB hub. Then I connected directly and now the Arcade MegaWing works! (At least I get VGA output, I didn't connect a gamepad yet and the PCB buttons don't really do that much).


I also tried to program the RetroCade without a hub in between but I get the same symptoms. I think I'll test if the voltages are stable and maybe how much current is consumed.

Link to comment
Share on other sites

There are a couple of things that bit me early on. One was a bad USB cable, brand new out of the box it had an intermittent connection. Others I've run across have insufficient current carrying capacity on the power supply lines, this can cause all sorts of weird issues. Some USB ports are inadequate in that regard as well, the Papilio pulls a fair amount of juice and can't tolerate a lot of voltage sag.

The other issue I had was with programming bitfiles into the configuration ROM. You have to remember to erase the ROM first before you load a new bitfile. That shouldn't affect loading directly into the FPGA though.

Link to comment
Share on other sites

did you get it figured out? if not, try this zipfile..

extract somewhere, replace the file 


with the proper one (the one there is just a place holder.. I don't use RetroCade so have no idea what bitfile to use..)

run the (PapilioDUO_TB.bat) batch file and use option 6.

the archive was meant for the papilio duo but in this case it should work for RetroCade.. didn't get around to making one for the PPRO =/



Link to comment
Share on other sites

  • 5 months later...

Thanks everyone for your help and sorry for the long inactivity -- I just pushed this to the side and the papilio has been catching dust for half a year.

What I tried since the last posts:

- Got a second Retrocade Megawing -> same issues with that, so it's not the extension board

- tried the whole thing on my work laptop with Linux64 instead of Win10/64, which was the only system I had on all of my personal machines

- set up an extra machine with Win7/32, since I figured the whole Papilio Platform seems to like 32 bit OSes

- also tried your loader, Felix -> behaves the same

- and, lastly, a different USB cable

When I load the bitfiles from the Win7 machine, I actually get Audio output and it even reacts to MIDI, but the firmware seems to behave erratic. LCD contrast is barely readeble (the "lcd contrast fix" bitfile doesn't display any text at all). One time it always played a high note when I released all keys from the midi keyboard. Songs from the menu always restart playback every 1/2 second while in the menu and play back normally when I switch to the next menu.

Writing the firmware to SPI flash takes about 262 seconds (SPI exec time; scan, erase and verify enabled), is that a normal time?


Best Regards, Henrik




Link to comment
Share on other sites

Hello Henrik,

Have you had any luck with running downloading DesignLab and loading some of the examples to the Papilio board? That might be a good place to start to make sure that there are no unexpected hardware issues lurking beneath the surface. If you can run the Papilio DUO Quickstart and some of the other Demos such as VGA output then that might help get us on the right track. It is also where the latest version of the Retrocade Synth software can be found.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.