Issues with new RetroCade (random notes)


Recommended Posts

I just recently started testing my new RetroCade synth along with a Papilio Pro and, aside from the LCD on my RetroCade having issues (not all of the characters on the bottom row display properly and only a vertical line moves across the top row rather than a 'space invader'.  Pressing on the black frame on the edge of the display while using male/female jumpers to connect it to the Retrocade fixes this so it seems it's just a bad connection on the LCD itself and not on the RetroCade PCB so I can probably find a way to fix that myself.) and it was also missing the small black cover for the five-way switch (I left a message via my GadgetFactory account regarding the button, but I think there may be an issue there since I didn't get a response so I just ordered a few spare button covers to have).  Those are fairly minor things, but I'm also having the issues that were described in the post linked below:

  1. All 8 Channels are called "SIDV1". Shouldn't there be at least one YM2149 channel?
  2. Channel 0 Drums don't produce any sound 
  3. Channel 1 seems to be the same as Channel 0
  4. Channels 2 - 7 are playing the last key pressed constantly, I can only stop when turning off the power
  5. When I press keys on my Midi Keyboard in Channel 0 too fast one these things will happen:
    • a broken bass noise appears
    • note off doesn't work until I press another key 
    • random notes are being played

I followed-up on that post by checking the chat session on gitter that was linked to in the post, but I didn't see anything about #4 and 5 in the chat log.  I'm using an old Kaysound MK-4902 midi controller that I've been using for ages and I have no issues with that controller and my other midi applications so I'm guessing there is something between it and the RetroCade that isn't quite right.  I was thinking I just got a faulty RetroCade unit due to the odd issues aside from the ones above I was seeing such as the LCD not working correctly, stopping, starting or changing examples files from SID, YMD, etc... on the smallFS  via the onboard five-way switch will often cause the RetroCade to either lock-up, start playing white-noise, random clicks/tones, or sometimes all of those odd things at once and I have to power it off/on to get it going again.

Using the RetroCade Synth Dashboard and the computer keyboard while connected via the com port doesn't seem to produce issues #4 or 5 above and switching between the three available MOD and YMD loops via the deshboard doesn't freak it out like it does when using the onboard joystick.

I've tried different USB power supplies with known good +5V and plenty of mA and the issue presents regardless of that so I don't think it is a power issue when using the MK-4902 external controller.  I've also used a midiplus USB 2-channel controller through my PC rather than MK-4902 directly to the RetroCade and that made no difference.

I'm using v1.3 of the bitfile.  When I load the .ino RetroCade exapmple from DesignLab 1.0.8 and enable debug I can see when the 'random' notes occur.  I will see the note I play, then an immediate noteoff (even though I didn't release the key) and then the message for a random note nowhere near the one I was playing and no noteoff msg for that random note.  I have to press another key to stop it.  It happens if I am playing slow or fast, but, 'seems' to occur more often when playing fast because it has more opportunities to show the issue.

I'm hoping there is a way to resolve these issues.  Seeing how at least one other person is having/had very similar issues I'm think there isn't anything defective with my RetroCade itself, but I suppose that is still possible.  I'd rather not have to purchase a new midi controller, but would be open to doing that if it will resolve the issue since I can't use the RetroCade 'stand-alone' with these issues at present.

My thanks for any suggestions or fixes for the issues I'm seeing.

Best regards,



Link to comment
Share on other sites

Update:  Even though I'm having no issues with the midi controller I'm using with other midi hardware/apps I decided to use a midi monitoring app to watch the messages being sent from the controller to rule out any issue with it.  When the 'random note' or note off issue occurs on the RetroCade I see no data being sent from the controller that would cause it within the monitoring application.  This controller is of the type that sends continuous 'Active Sense' messages, but I don't see how those would cause this issue with the RetroCade.

Link to comment
Share on other sites

Hi Jack,

Thank you for the response.  I've tried both the 'Audio_RetroCade_Synth' circuit and sketch from DesignLab 1.0.8 (loaded circuit first via lowest numbered com port for the Papilio Pro, then sketch uploaded via the higher numbered port) and also the:  RetroCade-1.3-lcd-contrast-fix-zpuino-2.0-PapilioPro-S6LX9-RetroCade-1.3.bit bitfile  which is the latest one I could find and seems to be the same one you linked to above.  Those are the ones I tried from the first time I unpackaged the RetroCade and both behave the same way with the issues listed.  I did try the 1.1 bitfile just for the heck of it and that was a no-go for sure.

Any other ideas on how I might troubleshoot this?  It is a bit perplexing to see the the erroneous midi commands show when looking at the debug via the RetroCade, but not seeing them when watching the midi traffic from the midi controller itself and also not seeing the issue at all when using the PC keyboard via a com port connection to the RetroCade Synth Dashboard.  Unfortunately I currently don't have access to another midi Keyboard to test with.


Thank you,


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.