Issues reading SD Card on Classic Computing Shield

Brad Robinson

Recommended Posts

Hi All,

First post here...

I'm in the process of porting my FPGA 80's home computer to Papilio Duo but currently stumped by the SD card.  I'm using a Papilio Duo and a Classic Computing Shield.

What I'm seeing is exactly like what's described in this post -  Basically the card initializes correctly as SDHC, a read command is issued, the read response returns success, the lead token on the data packet comes back as expected, but the data is all zeros.  I've double checked the data on the card multiple times and it definitely contains data.

The cause of the problem in the above post was related to voltage drops once the read starts.  ie: the card initialization and most register related commands worked but any access to the actual memory resulted in zero data due to a 2v drop.

So... I'm wondering if this might be a problem with the way I'm powering the board or with the shield itself.  I'm powering it via USB port from my Macbook but have also tried USB plugged straight into a iPhone charger.

Anyone else seen issues like this?  Any help resolving this would be much appreciated including suggestions of other projects/designs that are known to work that I could use for testing the hardware side of things.


btw: here's the details on my project - - it's an FPGA emulation of a Microbee which was an 80's home computer designed and built here in Australia.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.