Design Lab 1.0.7 Does not Like My Retrocade/Papilio Pro


Recommended Posts

I just dusted off my RetroCade MegaWing and wanted to try the 1.3 Synth code, but I'm finding that things don't seem to be compiling in DesignLab. I tried the loading a newer example from GITHUB, and loading the bit file, but it does not get very far. It has been a while since I have used DesignLab, but I recall that I had this working smoothly in the past. That was on an earlier version of DL, and the RetroCade code was 1.1.


Has anyone had the same problem using the RetroCade with a Papilio Pro?

Link to comment
Share on other sites

While this is specific to the RetroCade MegaWing paired with a Papilio Pro, I am posting here because what I am trying to compile are the examples included in DL 1.0.7.


I have found the problem with writing the bit file, so let me address that first, and then I will address what I can see when trying to compile the sketch.


The sketch I open is audio_retrocade_synth. The changelog mentions version 1.3, but the bit file link above it reads:


Click on the link below to load the latest production RetroCade bit file with all of the sample audio files

Two things to note here. The first is that the bit file pointed to is version 1.1. If this is the latest production file, and is compatible with the sketch, then I suppose that's O.K. I don't know if they need to be matched. The second is that the path to the bit file is pointing to the sketch root directory, but the bit file is in the circuit sub directory, so the line should read:
Now, when looking in the circuit sub directory, I do see a 1.3 bit file, but the size is only about 300kB. It should be larger, right? I did try to recompile the circuit, but there is an error. Save that for later.
Getting back to compiling the sketch, it seems to give up around the LCD code. There are lots of warnings about unused variables and parameters, a missing initializer for member `zfops::fstat', and the rest are just errors about various things. Mostly typedef conflicts and missing parens.
Link to comment
Share on other sites

For the first question, about the sketchdir://RetroCade-1.1-zpuino-1.0-PapilioPro-S6LX9-RetroCade-1.1.bit file.

That will not work with the sketch, it is only there because it contains all of the samples that you get if you are using the latest retrocade files available here:


It takes a very long time to load all of the samples from the smallFS folder so the best thing to do is to load this older bit file because it will write all of the samples to Flash memory. Then you will want to click the "Load Circuit" icon in DesignLab so that it will load the ZPUino 2.0 circuit that is associated with this sketch to the board. 


As far as the location of the 1.1 bit file, you are right it needs to be sketchdir://circuit/RetroCade-1.1-zpuino-1.0-PapilioPro-S6LX9-RetroCade-1.1.bit


For the second issue of not compiling. I'm sorry, we made the zpuino libraries more powerful and implemented a new sd card filesystem library. I thought we had updated all of the code to use the new stuff but it looks like this slipped through the cracks.


The fix is fortunately very easy:

  • Find the C:\DesignLab-1.0.7\hardware\zpuino\libraries\LiquidCrystal directory and open up LiquidCrystal.cpp.
  • On line 3 find: #include <stdio.h>
  • Please change it to: #include <zstdio.h>

This should fix the compilation errors. 


Ok, I'm going to work on a new release of DesignLab over the next couple of days to fix these and some other errors.



Link to comment
Share on other sites

So far so good. Each of your suggestions got me to the point where I was back in the day.


I tried generating the bit file, and got this


ERROR:Security:9c - No 'ISE' nor 'WebPack' feature version 2013.10 was available


I am on the latest WebPack, and I think the version is 2013.10.13. I don't have a clue what "feature" it cannot find.

Link to comment
Share on other sites

No, that's not it. My license is valid and installed. Installed an new license, and the error still occurs.


odd.  the xilinx site says thats a licensing issue.  expired license, or that the license you have doesn't allow you to use that particular device or module.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.