Papilio Pro FTDI faulty?

Christian Ruocco

Recommended Posts

Hi there,


I'm on Ubuntu 14.04 and after much faff trying to get my PP to work, I think it is knackered.


I get this when programming:


Programming to SPI Flash
Using built-in device list
Cannot find device having IDCODE=00010440
Unknown Papilio Board
Using built-in device list
Cannot find device having IDCODE=00400400
IOException: Cannot open file 
USB transactions: Write 4 read 3 retries 0
Error while burning bitfile.
The IDCODE fields seem to be random when I run papilio-prog several times. I assume that means the FTDI is mangling the serial data?
Any ideas? I've also got a DUO. Works perfectly with this same setup. I tried installing the linux 'drivers' but these seem to just install libftd2xx which isn't even linked against the papilio-prog (which uses open source libfdti) AND doesn't contain a linux kernel module either so I don't understand their relevance to anything. It does have a libusb in there though. Haven't tried that, get the feeling it's not going to help things.. The default FTDI drivers in Ubuntu work fine after running, with the Duo.  Minor note: Think it would be a good idea to remove all references to Spent a while searching the net for this script before discovering somewhere it is now  Error msg in DesignLab 1.0.7 still refers to too. 
Kind Regards,
Link to comment
Share on other sites

  • 3 weeks later...



I have a Papilio Pro that is working intermittently on 2 computers with Windows 7 and has same behaviour.


After many trials of uninstalling and then installing all drivers, and reboot of the PC, maybe it will start and I will be able to load a program on the FPGA or on the flash.


Next day if I’m lucky it will work, if not it will say “Invalid chain position 0, position must be less than 0 (but not less than 0) when I’m trying to program the flash.

When I’m trying to load the FPGA it will not return the control.


When it was working I tried a few times to access it with a Xilinx USB cable but installing cable drivers, or just coincidence, made it to not work at all.

Anyway, nothing is consistent even when I’m trying to reload the drivers, I mean it can work or not.


Do you think this is a hardware problem? I didn’t load more than 10 programs on this board so far. Could it be related to the drivers (I have a Xilinx USB cable, not a Xilinx USB cable II)?

Any advice will be really appreciated.


Best regards,


Link to comment
Share on other sites

Hello Adrian, 


Have you tried to eliminate the easy stuff, like a different USB cable, bypassing any hubs and connecting directly to a USB port etc?


If so then we can replace the board for you, the error message you are seeing usually indicates something wrong with the connection between the USB chip and the FPGA chip.


If you want us to replace the board please send an email to with a link to this forum thread and a current mailing address.


One problem though is that we are out of stock for Papilio boards so will have to wait for the next batch to arrive.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.