Papilio DUO – Program Arduino Bootloader using HappyJTAG2 tutorial not working atmel studio 6


Recommended Posts

I tried doing the bootloader tutorial but it did not work, i am wondering if it is a problem with atmel studio 6.2 software or with the atmega32u4, any help woul be aprecite it. attached is a screenshot of the happyjtag window, it seems that it recognizes the atmega but when i try to connect the board to atmel studio using jtag it does not appear anywhere in the tools.



Link to comment
Share on other sites

Hello Alex,


I think it might well be AVR Studio version, it was developed for the older version of AVR Studio 4. I remember testing with AVR Studio 6 and it did not work... I think its something minor but please try with AVR Studio 4 first to see if you can recreate the same.


I originally planned to work with the developer of HappyJTAG to better support AVR Studio 6 and etc, but unfortunately there has not been enough interest to justify the time. You are actually the first person I've heard of trying this out! It is pretty darn cool when you use it though. :)



Link to comment
Share on other sites

Ok so I am trying to connect to AVR studio 4 but the happyJTAG interface does not seem to be connecting to the AVR, I keep getting the could not communicate with comm 4 message, I am following your tutorial step by step and it still not getting anything at all.

I am having a hard time developing my program in Design Lab IDE as you might have noticed in my other topic. I also want to debug my program, so in any case that i can not get this working, could i use the JTAG pins in order to program and debug the AVR or is it only a feature reserved for the FPGA?

Link to comment
Share on other sites

Still no luck with the happy JTAG, now it does not even recognize the AVR signature. I noticed that the RX led is always on, so it appears that is receiving something, but I tried both SPI and JTAG and neither of them worked, I would really want to debug my code it is going to get messy and long. Is there another way to get an external debugger working with the AVR?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.