Recommended Posts



I tried the card I use for the acorn atom also for the atari 800 and it works just fine. I can load *.car and *.atr. So I think it is not my card that is the fault. I tried a Philips a Kingston and a sandisk card with my acorn atom. All the cards give a N/A sign in *HELP and *CAT.

I am monday free so I can get some measerements with my osciloscoop. You will here from me.



Link to comment
Share on other sites



Thanks for that info - very useful.


What's really weird in this case is it's failing very early on - at the CMD0 - and up to this point I can't see any difference between your flow chart, and what the Atom code is doing.


Can I ask what kind of speed the SD Clock would be running at in the Atari?



Link to comment
Share on other sites

I use this spi master hardware:


56Mhz clk, clk_div is set to 2. So I think about 14MHz but To be honest I never double checked with my scope or la!

Edit: of course init runs slow before the speed is boosted. I use a divider of 128 for that.

Oh and worth checking the code matches the flow chart:) http://www.scrameta.net/atarixlfpga_svn/trunk/atari_800xl/firmware/sd_direct/

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.