Problem with Papilio DUO Editing Circuits Quickstart tutorial


Recommended Posts


I got my papilio Duo today and tried the tutorials. The first two tutorials worked fine but I got stucked when doing the Editing Circuits Quickstart tutorial. I got an error message that some source files are missing.

(see the screenshot below) When ignoring this I get an error message when trying to generate the programming file.

Can someone help please?

Thanks, paul


p.s. I have tried editing another circuit but I always get the following error message when trying to generate the programming file:

ERROR:HDLCompiler:410 - "C:.....\cuircuit\DUO_LX9\Papilio_DUO_LX9.vhf" Line 173: Expression has 166 elements ; expected 201


Link to comment
Share on other sites

Hello Paul,


Did you ever use an earlier version of ZAP, Papilio Schematic Library, or DesignLab where you had to enter a .lib and .cat file? If so then that is conflicting with the new stuff, you will need to go to Edit/Preferences/Schematic Editor/Device Families and find the Spartan6 family. Remove all of the Papilio paths from all three options:



If that is not the problem then can you go back to the DesignLab IDE and do a tools/archive sketch and upload it here?




Link to comment
Share on other sites

Hi Jack,


you were right I had used earlier versions op ZAP and DesignLab, I did what you told and got it to work!

But the error message with the missing source files still shows every time for the ym2149_simle project. I checked "Remove unspecified files from project" then its ok, maybe there are some files that were left over. (the "missing" files are from a folder /Jack/Documents/...)

I also tried the quick start project and that worked and started without the missing source files message. But I have another problem with that project, it should blink the leds on any Button/Led Wing on any wing slot. This works correctly on all the slots with the exception of the CL wing, on that one the two middle leds don't flash. Can this be a hardware problem of my papilio duo or what else could make this happen? I checked the pin numbers of the script, they seem to be correct.


Thanks for your help


Link to comment
Share on other sites

Hello Paul,


Please place SW1 into the up position an you should see the middle LED's flash. If you look at the pinout diagram you can see that CL3-CL6 share pins with A2-A5 of the AVR chip. These are the JTAG pins and allow us to use the FPGA as a JTAG programmer for the AVR chip. With the getting started project the circuit connects SW1 to the reset line of the AVR. When the AVR chip is running it deactivates the JTAG port and the AVR pins act as Analog inputs so there is no conflict on the pins. But when SW1 is in the down position it holds the AVR chip in reset which in turn activates the JTAG port for programming which is interfering with those pins. 



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.