Unable to synthesize examples


Recommended Posts



I'm using the 1.0.1 version of DesignLab. I cannot compile any example project that I've tried. I've attached a screenshot from the PDF (view circuit) and Xilinx ISE schematic viewer (edit circuit) side by side which shows that the PDF circuit does not match the loaded schematic (note bus widths incorrect and completely different symbols for both VGA Wing and Papilio Default Pinout. This is from the VGA wing example, color_bar. I first opened the example, then created a copy and commented out the #define circuit as instructed. I then clicked edit circuit which opened the correct .xise file for my board (set in DesignLab) which is a Papilio Pro.


I think that my setup is incorrect for the Symbol Library but I don't know what to set it to. I've followed previous tutorials and guessed that I should point it to "C:\DesignLab-1.0.1\examples\00.Papilio_Schematic_Library\Libraries\Xilinx_Symbol_Library\Papilio_Schematic_Library.lib" after installing DesignLab (I previously had old versions of the schematic library 1.6 and 1.8 installed so Xilinx ISE was pointing there). If this is incorrect, how do I clear this out? I'm unable to leave these settings blank it seems.


I've also attached an error message during synthesis - hopefully this will help clarify what is wrong.


As a side comment, I've noticed that the .xise files that shouldn't be edited seem to point to Dropbox; perhaps the libraries haven't been updated completely in version 1.0.1 to whatever you're using on Dropbox?



Elaborating entity <Wing_GPIO> (architecture <Behavioral>) from library <designlab>.ERROR:HDLCompiler:410 - "C:\Users\user\Documents\DesignLab\Color_Bar\circuit\LX9\Papilio_Pro.vhf" Line 203: Expression has 148 elements ; expected 201Elaborating entity <Papilio_Default_Wing_Pinout> (architecture <BEHAVIORAL>) from library <designlab>.Execution of entity papilio_default_wing_pinout failedNetlist Papilio_Pro(BEHAVIORAL) remains a blackbox, due to errors in its contents--> 


Link to comment
Share on other sites

Hello ruzzmon,


The problem is indeed the old settings pointing to Papilio_Schematic_Library.lib. I figured out how to bypass the lib and cat files in the latest version of DesignLab, but if they are still setup in Xise then the old symbols will override the new schematic symbols. To remove the lib and cat files either delete the old version of Designlab or Papilio Schematic Library that the setting in Xise points to. Or go into Edit/Preferences/Schematic Editor/Device Families and then select Spartan 6. You will see three entries there where you can delete the offending paths. I can record a video later if needed.


I'm sorry for this issue, I didn't really anticipate this happening... I'm not sure if there is anything I can do to automatically fix this problem besides updating the install guide to say delete any previous versions of Papilio Schematic Library or DesignLab...


Let me know how it goes.



Link to comment
Share on other sites

Thanks Jack, that seems to fix the problem. I had to regenerate a new project file from an example for it to compile correctly though. I haven't tested it on the papilio itself yet but it does compile.


I don't think a video explanation is necessary; I used the Edit/Preferences/Schematic Editor method you suggested. I wasn't sure how to accomplish your first suggestion...I had pointed it to the current installation of DesignLab so I don't think I could exactly delete it at this point.


I think if you simply add an extra note on your installation guide this should suffice. Of course, this will only apply to users who have tried your Papilio Schematic Library previously, which DesignLab supersedes.


Thanks again!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.