New ongoing great project on Papilio Duo - complete Implementation of different Classic Computers (e.g. ATARI 8/16Bit, C64, Amiga)


Recommended Posts

  • Replies 68
  • Created
  • Last Reply



Unfortunately for me both PAL_VGA builds result in signal out of range on my old lcd (and no, it's too basic to provide any additional info about the signal)

The NTCS_VGA displays something blue, then resets - could this be due to me testing with a larger memory version of the DUO ?



Link to comment
Share on other sites

Many lcds only accept >56Hz, so pal may truly be out of range.

NTSC scandoubled should be ok on most lcd screens. I'll double check the build later on mine - been testing on my crt.

Is the larger sram chip also 10ns? I think I drive all higher address lines low but will check. ie higher men boards should work, but I don't have one to test with.

Did you set up the sd card with os/basic roms? Do you mean the 'atari basic' blue screen then it reboots?

Link to comment
Share on other sites

I'll try the bigger tv later on today when wife is asleep, that should at least give some hints if it doesn't like the sync.

The NTSC one seems to be ok for the monitor so i'd not waste much time on that.


The larger chip afaik is 10ns.


I *tried* to set the sd card up with the correct roms but... atari n00b :) Would that affect the boot-up behaviour ?

(**EDIT** removing the sd card will result with a flashing black/slightly less black screen)


i.e I don't know if it would be 'atari basic' blue screen. the blue blob is not rectangular, left side is 2/3 blue and drops like a sine wave to a 1/10 blue on the right side.

I'll try to take a pic for you when i get the homework done.

Link to comment
Share on other sites

@Lak: Yeah sorry ps2 port1 is flakey for me - not sure why. Should have mentioned that in the post about the build being up. Managed to run some program's ok?

@vlait: I checked on my lcd yesterday. The composite sync builds are working, but the separate sync builds are not. I found a dropped hsync pulse during vsync which is likely why. Did it work on your big tv?

Link to comment
Share on other sites

The manual is here:

Short version of sd setup:





See for atr files

Search on net for for roms

Hold option(f8) when booting to disable basic. Needed for lots of software.

Oh and keyboard in port 2.

F12 for menu

Link to comment
Share on other sites

Hey foft,


I just gave this a spin again. I loaded the required files to a SD card and loaded the build_NTSC_VGA bit file to the Papilio DUO with a computing shield. When I fire it up I just see a black screen with sync but no BASIC screen. I don't have a PS/2 keyboard yet so I'm wondering it that might be the problem? I'm supposed to be getting on in the mail in the next couple days so I will be able to test with it soon. The only other thing I can think of is that I used FAT32 on the SD card, does it need to be FAT16?



Link to comment
Share on other sites

Hi Jack,


This core? 

Just checking you realised they are not updated in-place. I just double checked this bit (I sample them, too many platforms to test all of them individually).


My monitor (Dell U2412M) is very tolerant, even 15KHz modes all work. Its always worth checking a 2nd monitor these days.


FAT32 should be ok, I'm using petitfatfs - You could try another sd card though, it does require 512 byte sectors etc and some cards have broken init. I should add some colours for different error codes. e.g. sd card init failed, rom missing etc.


It boots without keyboard fine, though its not so interesting to use.




P.S. I know you got a black screen, but any sound? The XL gives a bubbling sound on boot.

Link to comment
Share on other sites

OK! I just got my new ps/2 keyboard and fired the Atari 800 up. I was able to play Jet Set Willy. :)


I do have a little problem though. When I hit F12 and go into the system menu I can navigate just fine with both the keyboard and the joystick. But as soon as I select Drive 1 and it drops into a file selection mode I can no longer navigate correctly. Its like up is permanently triggering. I can move down if I hold the joystick or keyboard down button, but as soon as I let go it goes all the way to the top. I was only able to select JSW once by luck... Any ideas what might be going on?



Link to comment
Share on other sites

After some investigation... Its the same problem as with the PS2 port 1, ie conflict of some kind with the AVR. I checked R110 is definitely low, so the AVR should be in reset.


I checked the joystick lines on the scope and I see it periodically pulled low, when I'm not touching the stick.  The FPGA is definitely set up as input only on these pins. This does not usually happen immediately after I power on, but after some time. Once it happens flashing the core again does not fix it. So I suspect holding the avr in reset is not enough. 


Of course I should learn to write sketches, but for now is there any chance of someone kind making me a sketch to just put the AVR in high impedance mode? I'll modify my FPGA project to lock the AVR out of reset. I could connect it to SW1 but since that breaks the core probably not worthwhile!

Link to comment
Share on other sites



I just double checked and the PS2 port 2 pins are definitely not connected, nor should they be affected by the AVR chip. Here is a screenshot of the two traces in question:



Pins 39 and 41 are the pins for the PS2 port 2 pins and you can see they are very short uninterupted and not shared traces that go right to the FPGA pins... For whatever that is worth.


Here is a quick sketch that will setup all the AVR pins as inputs so they will be High-Z:

void setup() {  // put your setup code here, to run once:  for (int i = 0; i < 17; i++)  {    pinMode(i, INPUT);    }}void loop() {  // put your main code here, to run repeatedly:}

Please let me know if I can help with testing or anything.



Link to comment
Share on other sites

Its the joystick that is shared. PS2 port 2 works perfectly:-)

I just tried a similar sketch with no luck, will check your one. I as trying pin 0 to 1000 though perhaps that was an error;-)

Edit:My mistake, see below.

Here is a .bit without the arduino held in reset. (PAL, 31KHz, composite sync)

edit: in design lab is it meant to do anything after 'uploading...'? e.g. say 'upload complete' or similar?

Link to comment
Share on other sites

  • 4 weeks later...



I have used the atari for a while now and it works OK. I can't get any sound out of the atari 800. I am using the papilio duo with the Computing Shield.

The sound works just fine when I use the for example the Wing Audio sketch.





Link to comment
Share on other sites


This topic is now archived and is closed to further replies.