[newbie] problems with logicstart


Recommended Posts

Good afternoon,


I've started to learn VHDL two years ago, when I first found about the Papilio (I come from LXP and Arduino world) so I bought a Papilio One 500K and started to follow Hamster's FPGA course while waiting for my board.


Real life issues (moving from Trento to Berlin and after that back to Rome) have left me without the chance of "play" with my board (which has been sitting in it's box for some all this time). Now I've decided to go on with my Papilio and have ordered some Megawings to do more serious testing. 


My Logicstart Megawing arrived yesterday, and when I've plugged it to the Papilio, I've realized that something was not working well. I noticed that even if the Papilio Loader (I'm using v2.6) worked and uploaded correctly my bit files, they wouldn't work. It was just lighting on all the LEDs of the wing.


I.e.: Doing the first project of the FPGA course, all the LEDs of the logicstart lighted on, and I didn't got the behavior I was trying to program (switching the LEDs). As I was sure I was using the correct ucf file and pin numbers (I got them from the official ucf file), I couldn't understood why all the LEDs are on.


After trying not only with my projects, but also with the quick start bit file, everything was the same, so even if the output seemed correct, it wouldn't change the behavior of the board. I tried also the expert mode to check that it really erases the spi flash, and also tried to upload it directly to the FPGA. Always with the same result.


The problem was I was selecting the wrong size for my Papilio One (I tried 250K instead of 500K) and that caused the problem. Once I changed the target board in my projects, the bit file uploading worked like a charm. So I left this here just in case somebody runs in the same kind of problem I was having.


But now, after finding the problem, I've tried also with the ZAP IDE (v 2.3.0). I've followed all the steps (chose the correct version, loader, com port, upload the bootloader) but now, when I try to upload a sketch, I got the message: "Cannot get programmer version, aborting".


Obviously I have tried other cables and usb ports, with the same result.

Any idea? Am I doing something wrong?

Thanks in advance,

Link to comment
Share on other sites

Hello Julio,


I'm glad you found out the problem with selecting the 250K chip instead of the 500K chip. Thank you for sharing that one.


The problem you are experiencing with the ZAP IDE sounds like you have not loaded a ZPUino bit file to your board before trying to load the sketch.


The good news is that ZAP IDE is being replaced with DesignLab IDE and I am currently in the process of writing tutorials on how to use it. 


Here is an installation guide for Windows:



There is a Linux guide to be posted later today followed by a QuickStart guide.


I would recommend using DesignLab instead of the ZAP IDE and remember, there is an FPGA circuit associated with each sketch. So you need to make sure you have loaded the circuit to the FPGA before you can use the sketch. It should be more obvious in DesignLab.



Link to comment
Share on other sites

Hi Jack,


thanks for your answer!


Finally, yesterday I found the problem. When I plugged the Papilio, only one COM port was showing up. So I was choosing the wrong one.


After scouting the forum I found one topic (sorry, can't find the link right now) which solved my problem. The second serial (serial B) VLP check in advanced properties was disabled so it wasn't getting a port number or showing under my devices serial port list. Once I found that, everything is working fine!


So I'm really excited! Now I want to see what I'm able to build with this little buddy.


Thanks again,


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.