How to return Papilio Pro to "Factory Defaults"


chrisvdw

Recommended Posts

Hi there,

 

I received my Papilio Pro today so I'm very new to it.  The past few weeks I spent reading up, downloading the ISE and getting everything to more or less run in Ubuntu 14.04 LTS.

 

When I first connected the board to my USB port, the "User LED" was flashing. (I still have to earn my wings!)  I ran ZAP IDE and had the ASCII table printing out in the Serial Monitor.  I then copied and pasted the Papilio One QuickStart Example, compiled and uploaded it. After that, the ASCII is still printed (without the actual character), but the User LED no longer blinks, since the example is designed to blink the LEDs on the wing.

 

First, can you tell me where to get the bit file (and .bmm and .hex?) to restore the Pro to the state in which it left the Gadget Factory?

 

Second, how can I use the User LED myself in sketches?

 

Thanks,

 

Chris

Link to comment
Share on other sites

Hello Chris,

 

Thank you for checking out the Papilio. This is the test plan for the Papilio Pro that we use to prepare the board in the factory. This should be the direct link to the bit file.

 

Here is the source code for the QuickStart Guide used in the test plan.

Looking at line 266 it looks like the LED is mapped to pin 49 in the ZPUino circuit we defined for the test plan. If you use the bit file included with the test plan then you can access the LED using pin 49, but that hasn't been a standard for all ZPUino bit files that have been generated. I will work that into the ZPUino symbol for DesignLab so we have some standardization going forward.

 

Jack.

Link to comment
Share on other sites

Hi Jack,

 

Thanks, you are amazing, and surely one after seeing your responsiveness on the forums, one reason why I decided on the Papilio Pro rather than another LX9 board which I could maybe have gotten cheaper.

 

I tried both files and both works!

 

In the mean time I have used zpuino-1.0-PapilioPro-S6LX9-Vanilla-1.0.bit and at least were able to upload sketches again.  I did find out that the User Led is on pin 49.   I tried basically the same thing, but with the digitalWrite(49, ledState) right after the ledState = !ledState statement.  The LED did flash, but veery faintly.  I will still try to see what was the difference.  (And I could verify the LED was fine, playing with it in VHDL from ISE.)

 

Best regards,

 

Chris

 

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.