VGA LCD examples not working.


DaveC_nz

Recommended Posts

Hi, I have just bought a Papilio Pro and arcade mega wing and being a complete noob to all things fpga (I have done a bit of arduino programming) I thought I would start by playing with the ZPUino examples. All the VGA examples work fine (bricks, bars and hello world etc) except Zetris and none of the VGA Liquid Crystal examples work. They compile (all be it with a few warnings) and upload fine but I am left with a black screen. The sketch seems to be running as if I add the code to send some text out the serial port that happens fine I just have a blank screen on the vga output. I also seem to have the same issue if I try and upload any game using the 'ardade blaster' app. I get these results programming the board via windows or linux and I have tried several monitors with the same result. Is there something silly I am missing?

 

Cheers

Dave

 

Link to comment
Share on other sites

Hmmmm, I can't think of anything off the top of my head... I better do a check on my end and see if something is broken with the latest ZAP release. 

 

It's weird that Arcade Blaster app is not working... That hasn't been modified in some time...

 

Oh, wait! Did you write the ZPUino to SPI Flash? Please ensure that you are writing to SPI Flash and then after writing the sketch or Arcade game to the board do a power cycle and see if that makes a difference.

 

Jack.

Link to comment
Share on other sites

Yep wrote it to flash. As I said the other vga examples work fine as does the quick start examples. I also have a logic start board and the logic start sketch works fine but I have the same problem with that wing with the vga examples working fine (except zetris) but the vgalcd examples dont. If I upload a vgalcd sketch after I had one of the others (bricks or bars etc) running I get a frozen frame from that sketch stuck on the screen. If I cycle the power I get a blank screen. The problem with the arcade blaster appears to be different, it goes through the motions of creating the game but then stops 'writing game' very quickly after its starts and the board jumps back to whatever was previously loaded so its not doing the writing. I grabbed the pong bit file and uploaded using the papilio loader and that worked fine.

 

 

Dave

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.