papilio-prog on mac osx maverick


pirx

Recommended Posts

Hi,

 

I've been developing Papilio apps on my Macbook Pro. It has been

working great so far. Normally, I run ubuntu under vmware and download

bit files using papilio-prog.

 

Yesterday, I upgraded to Maverick.

 

Unfortunately, now I can't seem to get papilio-prog to work. If I run it

I get the following error.

 

% papilio-prog -c

Could not access USB device 0403:6010.

 

I recompiled the source, and I get basically the same message. I also

tried it using sudo.

 

I looked at /dev and now I get the following devices.

 

cu.usbserial-00001014B
cu.usbserial-141A
tty.usbserial-00001014B
tty.usbserial-141A

 

I think this has changed, but I can't remember what it used to show.

 

Any suggestions?

 

 

 

 

 

Link to comment
Share on other sites

I downloaded the Mac Installer. Installation worked fine.

 

But the programmer still can't access the device. Here is the message I get.

 

Could not access USB device 0403:6010. If this is linux then use sudo.

 

I tried it from the GUI and from the command line. On the command line, I tried

it with sudo. None of these attempts worked.

 

Pat

Link to comment
Share on other sites

I think I figured it out.

 

Mavericks now loads the FTDI drivers by default. In order to use libftdi, you need to unload the

driver. Here is what I did:

 

sudo kextunload -v -bundle com.apple.driver.AppleUSBFTDI

 

There may be another way to do this.

 

I haven't tried the serial port yet.

 

Pat

Link to comment
Share on other sites

  • 1 year later...

Hi I had the same problem, "Could not access USB device 0403:6010. If this is linux then use sudo" it was intermittent. Rebooting the computer seemed to help but it would fail after 10 mins or so. I found this forum and twoothers and tried the recommendations to no avail but then found at the end of this forum;

 

http://embeddedprogrammer.blogspot.co.uk/2012/07/hacking-ov7670-camera-module-sccb-cheat.html

 

The conclusion that the cable was the problem. I replaced my cable with a shorter one and it all worked! :-)

Link to comment
Share on other sites

  • 10 months later...

I've updated my last forum post on how to have the programmer and serial port active simultaneously (http://forum.gadgetfactory.net/index.php?/topic/1148-butterflyloader-on-macosx/?p=17129). This thread looks a bit old so I assume OP may not care anymore, but I'm posting here in the hopes that it'll will help anyone who lands here from google.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.