Cannot program Papilio One 250k


Recommended Posts

Hi, the Papilio One 250k just turned up and we followed the instructions to get it to work. We downloaded the no java Windows Installer, ran it, plugged in the Papilio One, the red light illuminates and two new USB Serial ports were found, COM45 and COM46. We then downloaded the P1_QuickStart.pde and the bit file. Double clicking the Bit file started the Papilio Loader program but the Run button was greyed out. After quite a few minutes, the Papilio Loader program showing the error message below. 


I tried changing the COM port to COM7 and COM8 but still no go. Any help would be much appreciated.









Link to comment
Share on other sites

OK, here is an update. Not sure what happened but it all works now. The even number pins flash and the ASCII table is being output at 9600 baud on COM8 fine. Please add a [sOLVED] to this heading if possible.


The only changes were to download the Papilio Loader with Java which is a much larger download and unplug the USB cable a few times. Maybe I should have mentioned my USB ports in the PC are pretty worn out since we have a business building and testing USB adaptors. Pretty sure the PC has been on the whole day.


Now when the Papilio loader is double clicked the bit file downloads in around 1-2 seconds. To program to flash, change the Write to FPGA to Write to SPI Flash and then the program will always run when the USB cable is used. It is pretty annoying that double clicking the bit file auto downloads and then quits but selecting File | preferences (when there is no Papilio connected) allows this option to be turned off. Thanks - great value.

Link to comment
Share on other sites



The command line options are configurable at install time as well as runtime, where you can select one of the following:


- Write to SPI flash and quite

- Write to FPGA and quit

- Start Papilio loader and wait


In case of first two options, application will quit only when it can write the bitstream to FPGA or SPI flash successfully. If any error occurs it will not quit and keep the error messages for the user.


If one wants to remove the quit step from the first two options above, all you need to do it update the registry setting a tad. Open the following key (see attached image):





HKEY_CLASSES_ROOT\Papilio Loader bitstream\Shell\WritePermanently\command


or whichever command you wish to modify (from 'EraseFlash', 'Open', 'WritePermanently' or 'WriteToFPGA' ) and remove the switch '-x' from the command line.


For example, 'WritePermenantly' option has command line as follows:


C:\Program Files\Gadget Factory\Papilio Loader\papilio-loader.exe" "%1" -s -q -x


Simple remove "-x" from the above command line so that the loader will not exit whether the operation is successful or not.


Please see for detailed description of the application.





Link to comment
Share on other sites


This topic is now archived and is closed to further replies.