Papilio Pro Beginner Tips


Recommended Posts


It is now December 2016 and I bought the papilio-pro about a month ago after reading the spartan introduction book and learning about the zpuino . I previously owned a Basys2 board and wanted something new. I bought the logic analyzer set with the papilio pro board and expected (after looking at the video's and such) that it would be a smooth experience to get this stuff running.

by now I did gt some basic sample running (e.g. blinking a led) but it was quite a struggle.


-papilio-prog binary for linux where outdated (e.g. targetting 32 bits platform)

-papilio-prog source code was not compiling

-bitfiles to program the pro flash where missing and the VHDL source code was incomplete

-There where(are) no ready make bitfiles to turn the pro into a logic analyzer

-There is no official place to download the modified source for the SUMP logic analyzer and download have been broken/ don't work

-In the last 15 days nobody cared to answer anything on IRC

Can somebody/gadgetfactory help me get the basic VHDL SUMP source so we can make a fully working system again?

I would like to be able to publish a full set of source code on something like github for people to get a better experience.

I am also considering spending some time on making it possible to flash openocd(or urjtag) to program the board as that code is more actively maintained.


More notes from IRC bellow:

08:50 < keesj> Hi
08:51 < keesj> I recantly bought a papillio pro and now taking the time to get started with that board
08:52 < keesj> I have some previous experience with VHDL/fpga (reading the intro book) and running samlples on a Basys2 board
08:54 < keesj> I have bought the logic analyze kit with a pro board and want to gets things running (using linux) but I amexperiencing some hurdles to take to do that
08:54 < keesj> the download of the flasher only contained a 32 bits version hence I had to download the souce code and make small modifications (just to make it compile again)
08:55 < keesj>
08:56 < keesj> this was the error log and this my current patch "to make it compile"
08:56 < keesj> unteted yet. Now I am trying to get started reading
08:57 < keesj> but I can not download the bit files (I get a timeout) nor can I download the source
08:58 < keesj> the link to the java client is broken Java Client - Download the latest client from Jawi's Alternate Client Homepage
08:59 < keesj> and there is a smal typo on the page (the text reads twice " Ready to run bitstream for the Papilio One 500K board. Version 2.12, use Papilio Loader to load the
               bitstream. ") While the second time it shoud be about the 250K version)
09:03 < keesj> it looks like the bitstream can also be found in the git repo under Helper_App/bitstream_archive
09:19 < keesj> I also had to create a udev rule to allow writing to the board as normal user
09:40 < keesj> Next I am haveing a problem wit the programming/programming
09:40 < keesj> Device failed to configure, INSTRUCTION_CAPTURE is 0x19
09:42 < keesj> with an other files worked
09:47 < keesj> I was wondering. what transfer speed can I expect for the logic analyzer ? it it somewhere near usb 2.0 speed e.g. 24 MB/s?
11:02 < keesj> the link on for the SDRAM is broken
14:33 < keesj> Hmm from the looks of it I need to compile a version for the XC6SLX9 myself.
14:34 < keesj> Kinda weird given I have bought the pro with the logic wings in a Logic anaylzer package
15:10 < keesj> some work was already done here
15:18 < keesj> the forum pages do no longer contain the source code
15:19 < keesj> going down the rabbit hole here
22:27 < keesj> I guess I am a little later to the party
22:27 < keesj> also looks good but again missing links
22:29 < keesj> is zo cool






Link to comment
Share on other sites

Hello Keesj,

All of the latest tutorials and information is at the GadgetFactory Learn website, please consider that as the latest and authoritative location for information and tutorials. The majority of Papilio users are windows users and so that is where the majority of the work goes. I personally prefer to use Linux but I have to be sensible and develop in the environment that is used by the vast majority of users. I do my best to keep the Linux side of things running smoothly but there are only so many hours in the day... The linux side of things is a bit more hands on then the windows side, because there are much fewer linux users and they generally are more then capable of handling anything that comes up... If you want an experience that just works and is smooth and seamless like you say you expected from the videos then please use Windows, by using Linux you are going off the beaten path and should expect some bumps... 

Also, please do not feel like you were ignored on IRC... Please take a look at the topic and you will see that it was set in 2011! Back then I had a link to the IRC channel setup on the main papilio website, but that has been gone for at least three years now and nobody has used the IRC channel since then. It is only kept open by a couple users that still have #GadgetFactory in their IRC channel list and keep connecting to it... Having said that, I am considering going back to it since the slack chatroom that I setup is not working out as it is too exclusive. I am currently logged into the IRC channel again and will try to stay logged in. Posting to this forum is the best place to get your questions answered. From my perspective this is the first time I have heard of your struggles, if you would have posted in the forum I would have been all over answering your questions.

Here are answers to your questions:


-papilio-prog binary for linux where outdated (e.g. targetting 32 bits platform)

-papilio-prog source code was not compilin

I suspect you were working off old information, the latest tutorials are on the learn website:

Designlab is the preferred way to use the Papilio and is what the Papilio videos are referring to. It has a compiled version of papilio-prog and papilio loader built in. It also lets you quickly use the Logic Analyzer. I suggest you start with DesignLab and look at the tutorials at the Learn website.


-bitfiles to program the pro flash where missing and the VHDL source code was incomplete

I'm not sure what you are referring to here.


-There where(are) no ready make bitfiles to turn the pro into a logic analyzer

Here is a tutorial showing how to quickly use the logic analyzer in DesignLab. Most people are not looking for bit files to turn the pro into a logic analyzer but prefer to use DesignLab. If you really just want the bitfiles you can download DesignLab and get them from the following folder: DesignLab-1.0.7\tools\logicanalyzers.


-There is no official place to download the modified source for the SUMP logic analyzer and download have been broken/ don't work

Can somebody/gadgetfactory help me get the basic VHDL SUMP source so we can make a fully working system again?

Everything I have ever worked on is already checked into Github... The original Sump Blaze core is here, but that is old now. All of the latest stuff is built into DesignLab... The Logic Analyzer bit files provided in DesignLab are available by opening DesignLab, going to examples, and selecting Benchy_Sump_LogicAnalyzer_Standalone. Click the "Edit Circuit" icon and you will see the Logic Analyzer circuit inside Xilinx ISE. You will find all the source code to the left. The github location is here and here.

Hope this helps.


Link to comment
Share on other sites

Hello Jack,

Nice to get some feedback. on the subject of the loader


I started by downloading ( sha1sum 565f278f7190b04eb7612cd2cdf998119b687070 )
As I just did from

the zip contains the following:

keesj@700z:~/Downloads/tmp$ unzip ../
Archive:  ../
  inflating: papilio-loader/license.txt
  inflating: papilio-loader/papilio-loader.exe
  inflating: papilio-loader/papilio-loader.jar
  inflating: papilio-loader/readme.txt
  inflating: papilio-loader/help/index.htm
  inflating: papilio-loader/help/images/expert-mode-screen.png
  inflating: papilio-loader/help/images/installer-preferences-screen.png
  inflating: papilio-loader/help/images/papilioRed.css
  inflating: papilio-loader/help/images/simple-mode-screen.png
  inflating: papilio-loader/images/loader_about.png
  inflating: papilio-loader/images/right_arrow.png
  inflating: papilio-loader/programmer/bscan_spi_xc3s100e.bit
  inflating: papilio-loader/programmer/bscan_spi_xc3s250e.bit
  inflating: papilio-loader/programmer/bscan_spi_xc3s500e.bit
  inflating: papilio-loader/programmer/bscan_spi_xc6slx4.bit
  inflating: papilio-loader/programmer/bscan_spi_xc6slx9.bit
  inflating: papilio-loader/programmer/linux32/data2mem
  inflating: papilio-loader/programmer/linux32/devlist.txt
  inflating: papilio-loader/programmer/linux32/papilio-prog
  inflating: papilio-loader/programmer/linux32/srec_cat
  inflating: papilio-loader/programmer/win32/data2mem.exe
  inflating: papilio-loader/programmer/win32/devlist.txt
  inflating: papilio-loader/programmer/win32/papilio-prog.exe
  inflating: papilio-loader/programmer/win32/srec_cat.exe
  inflating: papilio-loader/
  inflating: papilio-loader/papilio_48.png

After a chmod +x I still can not execute the shell file

keesj@700z:~/Downloads/tmp/papilio-loader$ ./
-bash: ./ /bin/sh^M: bad interpreter: No such file or directory

This is probably because the file is encoded using a dos formatting

keesj@700z:~/Downloads/tmp/papilio-loader$ dos2unix
dos2unix: converting file to Unix format ...

Now the loader start working (but I don't give/want and need to give this program root access

keesj@700z:~/Downloads/tmp/papilio-loader$ ./
[sudo] password for keesj:

hence I start looking at the script(removed the sudo)
next I start the script and have the next problem the jar file is expected somewhere.
Error: Unable to access jarfile /opt/GadgetFactory/papilio-loader/papilio-loader.jar

I give up on the script and start looking at the binaries(found papilio-prog in papilio-loader/programmer/linux32)

the programmer ./papilio-prog is lacking

./papilio-prog: error while loading shared libraries: cannot open shared object file: No such file or directory

and installing a 32 bits version of that is getting challenging on my system(ubuntu)

Worse for me is 32 the bits programmer
keesj@700z:~/Downloads/tmp/papilio-loader/programmer/linux32$ file papilio-prog
papilio-prog: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked, interpreter /lib/, for GNU/Linux 2.6.24, BuildID[sha1]=c9377304b85ce73f71204787840ec0d71880d452, not stripped

This is where I started downloading the code from github and found

(the source code there doesn't compile on my ubuntu install without some modifications (changed posted on pastebin))

By missing bit code and such I was referring the code found there. has
but lack the constrains file and other things like archives of the LogicAnalyer bit files (lacking the lx9)

so this is why I ended up there (there are a few more similar problems like ./linbin/diago missing the ncurses library.

I will follow the tutorials you mentioned but still would like that the wiki pages I mentioned to get updated as it was not hard for me to find them!

And I am looking forward to finding the SUMP VHDL code for the papilio pro!


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.