Spartan 3E Starter Kit problem


Recommended Posts

Hello everyone,

i was blowing away the dust from my S3E starter kit to play with it at home.

All went smoke I mean. I programmed the ZPUino (the Alvie file zpuino-1.0-S3EEvalBoard-S3E500.bit ) but when I tried to run the demo sketch, I got an "Unknown flash type" error.

It is a long time since I played with the ZPU, so maybe I am doing something silly..but at around midnight, I am not yet out of it, so I must ask for some help and go to sleep.





Link to comment
Share on other sites

  • 3 weeks later...

This seems to happen with some boards (I suspect Digilent ones), design works fine in my Official S3ESK.


The issue is some increased delay of the SPI flash, and can be corrected easily. I'm synthesizing a new bitfile with some more safe values.


I'll let you know when it's done.

Link to comment
Share on other sites

HI Alvie,

I tried the bit file, but Impact does not allow me to assign it to the S3E. "A BIT file describing an is about to be assigned to a device identified as an XC300S500E". Frankly, i did not undesrtand what it meant. Maybe you compiled the project with a different device target?.




Link to comment
Share on other sites

  • 3 years later...

I have just downloaded the image you have proposed and it works for me. I have a Digilent s3e board. However, when I am using the zpuinoprogrammer, I am now getting:

sudo ZPUino-master/build/linux/zpu-tools32/zpu/bin/zpuinoprogrammer -v -R -s 115200 -d /dev/ttyUSB0 -b ~/Downloads/s3e_demo\(2\).bin
Got programmer version 1.9
SPI offset: 0
CODE size: 28544
Board: Spartan 3E Starter Kit S3E500 @ 96000000 Hz (0x83010f00)
SPI flash information: 0x20 0x20 0x15, status 0x00
Detected M25P16 flash
Will program sector 0 (page 0), original offset 0x00000000
Need to program 2812 2816 bytes (11 pages)
File '/home/spanosa/Downloads/s3e_demo(2).bin' does not appear to be a sketch: 0x00000000 != 0x310afade


I am using the example binary that can be found here.

I have two questions:

  1. How do I build the pde?
  2. Would you have an idea why this command doesn't work?



Link to comment
Share on other sites

Hi Alvie,

So I have checked out the version:

commit e76688199439f35504343f536c9fd9cfc82e7682
Author: Alvaro <>
Date:   Sat Jul 16 18:37:13 2011 +0100

    boards: fix up some boards

because it is my understanding based on the board ID and the behavior of the binary that this is the one whose binary can be found here.

As it is expected I am getting the same error, e.g. Unknown flash type ... Exiting. Could you please let me know which version of the code leads to the binary that you attached on this comment?

All the best,


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.