Building ZPUino HDL


Recommended Posts

I've grabbed the most recent ZPUino HDL and tried to build it "all".

Basically I tried to build every Makefile under "zpu/hdl/zpuino/boards"

for i in `find /mnt/scratch/ZPUino-HDL/zpu/hdl/zpuino/boards/ -name Makefile -printf %h\\\\n`; do
cd $i
make | tee $i/Makefile.out

A number of the makes failed.




Are we expecting failures in these makes, or is it something about my setup?

Link to comment
Share on other sites

That's indeed my problem, sorry. I've been pushing stuff into repo that I should not.

Nexys3 support is preliminary however, so it won't build.

I've pushed some changes that should fix the above issues.

Question: why are you synthesizing all of the boards ? Should be faster if you only synthesize those you own.



Link to comment
Share on other sites

Oh, I was just going to start playing with a few things, and wanted to make sure I didn't break any interdependencies.

Some didn't build, and since I'm quite new to this, I wasn't sure if it was my setup - or a real build problem. (I've had all sorts of fun getting ISE to run - glibc crashing craziness :angry: )

Synthesizing all of the boards is really just a sanity check for me, I wasn't harassing you for a fix. ;)

Link to comment
Share on other sites

Looks like the new drop breaks a few things:

ERROR:HDLParsers:3312 - "/mnt/scratch/ZPUino-HDL/zpu/hdl/zpuino/zpuino_intr.vhd" Line 194. Undefined symbol 'Undefined'.

It appears that "Undefined" was introduced in:

But seems to be missing from most of the board "zpu_config.vhd"s

Or... it could be me...

I've tried to drop my make logs here (WARNING - not very stable at the moment):

Link to comment
Share on other sites

*sigh* Except that I did mess up, and add a dupe.

There's still some issues stopping /papilio_one/s3e500/variants/hyperion/ from building

Compiling vhdl file "/mnt/scratch/ZPUino-HDL/zpu/hdl/zpuino/boards/papilio_one/s3e500/variants/hyperion/../../../../../wb_char_ram_8x8_sp.vhd" in Library work.
ERROR:HDLParsers:3264 - Can't read file "/mnt/scratch/ZPUino-HDL/zpu/hdl/zpuino/boards/papilio_one/s3e500/variants/hyperion/../../../../../wb_char_ram_8x8_sp.vhd": No such file or directory

When I sort it out, and get it to build, I'll send another pull request.

Also the / zpu / hdl / zpuino / boards / papilio_one / s3e500 / variants / apollo seems to missing it's PRJ file. Did it get forgotten, or doesn't really exist yet?

P.S. At the moment, my latest build logs are at: built from my fork.

Link to comment
Share on other sites

Sweetness & light. ;-)

Nice work. Looks like only the nexys3_S6LX16 & the papilio-plus_S6LX4 don't Make nicely at the moment. - ERROR:HDLCompiler:636 - "/mnt/scratch/ZPUino-HDL/zpu/hdl/zpuino/boards/nexys3/S6LX16/nexys3_top.vhd" Line 365: Net <gpio_o[52]> is already driven by input port <I>. https://raw.github.c...xys3_S6LX16.log - Seems to be a problem building the bootloader. ../common/register.h:9:33: board_papilio_plus.h: No such file or directory


My current logs (and build output) @

Link to comment
Share on other sites


hope not be off topic, but I was playing with papilio-plus and the arcade wing and, loading the sketches on the "zpuino-1.0-PapilioOne-S3E500-VGA160x120x8.bit" resulted in a good image but the foreground and the background of the writings are the same (cannot be read).

Strangely, loading the old Z2 version resulted in the opposite behaviour: nice writings but no image.

I checked the code for the IO_slot but seems to be OK. I don't know how to get the old build to compare the diff.

Any hints?

Link to comment
Share on other sites

Simply downloaded from the links in the gadgetfactory site. Anyway I have not expressed myself correctly. What i was trying to do was to get the zb2 sources for ZPUino to compare the two projects that led to the two bit files reported below. . In particular I expect that there should be some diff in the ZPUino_VGA and ZPUino_vga_char_ram.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.