Help needed with Arcade Mega Wing

Guest williamlee

Recommended Posts

Guest williamlee

I just received my Papilio 500k and Arcade Mega Wing.  I'm hoping someone

  can help me with an issue I am having.  I am unable to get any video

  output over the VGA port on the Mega Wing.


  I have confirmed that the Papilio appears to be in working order by

  uploading the hello world program and monitoring the serial port

  output.  It cycles through the symbols as expected.


  I then successfully uploaded the ZPUino Soft Processor with HQVGA

  targeted for ArcadeWing from the site, and hooked up the Mega Wing and

  plugged it into a VGA monitor, and then gave it power over the USB

  port.  Unfortunately, I am getting nothing on the monitor display.


  I am a beginner to FPGAs and the Papilio, so I was hoping someone would be

  able to suggest additional troubleshooting.  I am hoping it is

  something simple I need to tweak.


  Thanks in advance for any help!

Link to comment
Share on other sites


Sorry for the hassle, the MegaWing is still a work in progress and I'm still getting  all of the documentation in order. A quickstart guide for Zetris is next  on the list, but in short, what is happening in your case is that  loading the ZPUino soft processor is just the first step. The ZPUino  soft processor will sync the display but without any code running on the  processor it does not actually do anything. So here is a quick rundown  of the steps to take:



  I am working today on getting the  arcade projects updated with the ucf file for the MegaWing and a  quickstart for Zetris.


Link to comment
Share on other sites

  • 6 months later...

i have the same problems as this guy (William did you ever figure it out?)

i tried your suggestions about zpuino/zetris but the IDE complained about no

VGALiquidCrystal library.

the generic VGA 'hello world' doesn't seem to work either.

The demo one included with PapilioProgrammer works fine

(outputs the ascii stuff on the serial port)

are all the Via's on the Arcade MegaWing v1.1 supposed to be populated ?

[see attachment]


Link to comment
Share on other sites

Hello Felix,

It's ok not to have those headers populated on the Arcade MegaWing board. There are six different places that power can be drawn for the components and those two places are not used.

Have you been able to get anything running on the board yet? I recommend that you download the new [[|Arcade Blaster app]] to establish that the hardware works. The Arcade Blaster app comes with the Pong Demo ready to go, it should just take a couple seconds to load it onto the hardware. Then, if you  own any of the MAME ROMs listed [[|here]]  you can provide them to the Arcade Blaster just like you would to MAME.

The error you are getting about the VGALiquidCrystal library is my fault. I thought that the library was included with the latest version of the ZPUino, but it looks like that is not the case. We will work on getting the library released.

Are you trying to get the VGA Hello World example from this page working? The key to getting this to work is to make sure you follow the guide to setup the ZPUino here. The key thing to note is that with the ZPUino you need to program the processor to the FPGA before you try to load a sketch to it. With the AVR8 the code is merged into a bit file that contains the soft processor and both are uploaded to the FPGA at the same time. But the ZPUino works differently, you load the ZPUino to the FPGA and then it waits for the IDE to upload code to it. It then stores that code in SPI Flash and will then copy the code into its internal RAM and start execution. So the bottom line is that you need to ensure you have loaded a ZPUino bit file to the Papilio before you try to send code from the IDE. It is recommended that you load the ZPUino bit file to SPI Flash.

Let me know how it goes, maybe I need to make changes to the wiki pages to make this clearer.


Link to comment
Share on other sites

thanks for the reply. I tried the arcade blaster app (yesterday)

only app problem i ran into is i had to set it to run in Win XP sp3 compatibility mode / run as admin

under windows 7.

however i got no video / sound out from the wing.

having said that, i am trying with my flatscreen tv but i will try with a real monitor soonish.

what is odd is that i got no audio out when i put a headset on (pacman or pong)

also there is a typo in the games xml file with the arcade blaster.

it says 'homwbrew' or something instead of 'homebrew'

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.