gigcon

Getting Logic Analyzer working on Ubuntu Linux

5 posts in this topic

For those of you who might try to launch Logic Analyzer from DesignLab on Linux, let me share what I had to do to get that working.

Although it is not very obvious from the getting-started video, the logic analyzer GUI should pop up automatically once the logic analyzer bit file is uploaded to Papilio. I was wondering if I had to do anything at this point because I wasn't seeing a window pop up. It eventually turned out that there were two problems in my case.

1. The OSTYPE environment variable is expected to be "linux-gnu", according to the script tools/Logic_Analyzer.sh, but it was "linux" in my case.  You have the following at the very beginning of the script:

# Simple check to see whether the "magic" Java binary is available on our path;
if [[ "$OSTYPE" == "linux-gnu" ]]; then
	java -version 1>/dev/null 2>&1
else
	../java/bin/java -version 1>/dev/null 2>&1
fi

The "else" part is for Windows and some other platforms where JRE is bundled in the DesignLab installation. Since $OSTYPE == "linux" in my case, java didn't launch at all.

2. The java program is incompatible with Java version 1.8, but works with version 1.7. The JRE version that comes bundled with the windows version of DesignLab is version 7. In my case, java 1.8.0_91 was launched and it essentially hung after printing out lots of messages like the following:

ERROR: Bundle nl.lxtreme.ols.tool.1wire [33] Error starting file:/home/puser/DesignLab-1.0.7/tools/ols-0.9.7/plugins/1wire-1.0.0.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.tool.1wire [33]: Unable to resolve 33.0: missing requirement [33.0] osgi.wiring.package; (&(osgi.wiring.package=nl.lxtreme.ols.api)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 22.0: missing requirement [22.0] osgi.wiring.package; (osgi.wiring.package=nl.lxtreme.ols.util) [caused by: Unable to resolve 25.0: missing requirement [25.0] osgi.wiring.package; (osgi.wiring.package=javax.accessibility)]])
org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.tool.1wire [33]: Unable to resolve 33.0: missing requirement [33.0] osgi.wiring.package; (&(osgi.wiring.package=nl.lxtreme.ols.api)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 22.0: missing requirement [22.0] osgi.wiring.package; (osgi.wiring.package=nl.lxtreme.ols.util) [caused by: Unable to resolve 25.0: missing requirement [25.0] osgi.wiring.package; (osgi.wiring.package=javax.accessibility)]]
	at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
	at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
	at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
	at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
	at java.lang.Thread.run(Thread.java:745)

This is solved by changing references to java to /usr/lib/jvm/java-1.7.0-openjdk-amd64/bin/java.

Once that's done, I get he logic analyzer GUI and it is working.

Hope this helps. As a primarily-linux-based user, I seem to have many more hurdles to jump than an average windows user with DesignLab. :(

I actually tried running on Windows as well, but at this point, I can't do anything as Windows 10 gives me the blue screen with NO_MORE_IRP_STACK_LOCATIONS error just a moment after I plug in Papilio at this. I know this is not a problem with papilio or the driver that comes with it, as I have used it successfully some time back. But for some reason, I am getting this crash now and haven't figured out how to fix it yet.

Share this post


Link to post
Share on other sites

Hello gigcon,

Just wanted to verify, you are using Ubuntu Linux? Is it the latest version? When I set everything up it worked with the latest version of Ubuntu, but things probably changed since then...

Thanks,

Jack.

Share this post


Link to post
Share on other sites
On 7/10/2016 at 11:26 PM, gigcon said:

 

Hi Jack,

 

It is Ubuntu 14.04 LTS, which is not the latest.  Centos/Redhat 6.6 say reports the same -- just "linux".

Share this post


Link to post
Share on other sites
On 7/11/2016 at 6:01 PM, Jack Gassett said:

Hello gigcon,

Just wanted to verify, you are using Ubuntu Linux? Is it the latest version? When I set everything up it worked with the latest version of Ubuntu, but things probably changed since then...

Thanks,

Jack.

Hi,

The same applies to ubuntu 16.10.I suggest upgrading to ols-0.9.7.2 (for java 1.8 support)

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now