pmoyle111

How to get ISE to recognize Papilio I for file download

Recommended Posts

Hi all,

 

I did not see a quick start doc. I plugged in Papilio One and then fired up Impact. It found a xcz7045 I had forgotten was plugged into another cable so I unplugged that, restarted the Impact, but it found no devices. What do I have to do?

 

BTW, while I'm here...does anyone have any generic ucf files I could hack from as a test starting point?

 

 

Thanks,

 

 

Peter Moyle

Share this post


Link to post
Share on other sites

Quick start doc:  http://papilio.cc/index.php?n=Papilio.GettingStarted.  It describes the Papilio Loader app which can take a ".bit" file produced by ISE and load it onto the FPGA.  It's all I've ever used.  I don't know if anyone has managed to get ISE to program the Papilio directly -- I vaguely recall hearing about it, but when I looked for the info now I couldn't find it.  Maybe someone else will post the details.

 

But all I've ever used is the "papilio-prog" command line, from the Papilio Loader app.

 

Regarding UCF files, the GadgetFactory site has a few downloadable UCF files for the different boards.  For example, http://forum.gadgetfactory.net/index.php?/files/file/2-papilio-one-generic-ucf/.  You take the file, copy it, and edit to remove any pins you're not using in your design.

Share this post


Link to post
Share on other sites

Thanx for the above,

 

That got me going a little. What my goal is, is that I'm working on a test bring up board for a new chip where the ZC706 board is the base platform and the test board is a module that plugs in the FMC connector. I'm using the Papilio as a test vehicle to reduce risk resulting from problems like I'm having now.

 

I got a look at the video Jack had posted about using Impact and went thru and did all the things. But my set up places a Papilio One in the Jtag chain with the FMC board that chains the Jtag from the Zync chip whereas his was standalone. I have also removed the 68R resistors on Papilio in a attempt to isolate the FTDI from the Jtag electrically but the result was the same as using the software FT_Prog solution demonstrated by Jack.

 

I have determined that the problem is most likely due to the fact that the ZC706 is using Jtag with 3.3 volt reference and the Papilio One is using 2.5V Jtag.

 

How can I modify the Papilio to accommodate 3.3V on Jtag? I have looked thru the XCS250E specs and it is unclear to me how to change it. (I realize it may require lifting some pins and placing some jumper wires.)

 

Peter Moyle

Share this post


Link to post
Share on other sites

Rewiring and JTAG are outside my expertise, sorry.  But I will note that according to the Papilio One Hardware Guide (http://papilio.cc/index.php?n=Papilio.PapilioOne), JTAG on this board already operates between 2.5V and 3.3V levels.  It says the FTDI chip is 3.3V while the Spartan 3E's JTAG port is 2.5V.   So maybe the problem is something else?

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now