F6EEQ

Trouble with simulation

5 posts in this topic

Hi all,,

 

I tried to use simulation, using the guidelines in Hamsters book.

I have the test bench OK, but when I double click on "sumulate", I get an error message saying: "model technlogy vsim unavailable".

When I go in "preference/tools" the first line is blanck, and I am not able to find the path to the simulator.

 

I'm not sure it is installed.

 

Any hints?

 

Thanks.

 

Share this post


Link to post
Share on other sites

You either want to download and install modelsim separately or choose Isim. Isim is what comes built into ISE and you can use it without installing anything else, you just need to select it as the default.

 

Jack.

Share this post


Link to post
Share on other sites

OK Jack, but I tried and could not find where Isim is in the Xilinx directory.

 

The line "Model Tech Simulator" is blank and if I click on "default", nothing's happening.

I'm not sure that Isim has been downloaded with ISE.

Share this post


Link to post
Share on other sites

This is what I do to make sure ISim is selected:

 

Right click top level file in the "Hierarchy" pane and select "Design Properties".

A new window will pop up and one of the options is, "Simulator" Make sure ISim (VHDL/Verilog) is selected.

 

That's usually all it takes.

 

Jack.

Share this post


Link to post
Share on other sites

OK Jack and thanks.

 

Now it's working. Not as I wanted, but this is another story!!

At least I get some time frame and the clock

 

ISE help is not very helpful in setting up all those things!

 

Have a nice WE.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now