kimi

Cant find LX9(Pro) with ZAP Linux IDE ?

Recommended Posts

Dear All,

 

I  have install GCC, and downlad the Full IDE, release 1.0, linux x86

 

But I cant find LX9(Pro) with  1.0 IDE?

 

Any solution?

 

Tnank you

 

K

Share this post


Link to post
Share on other sites

Hi, I'm not quite clear about your post, particularly about GCC or version 1.0.  But I shall assume that what you're wanting to do is use ZAP Arduino environment with Papilio Pro. 

 

So, for starters the thing you need to install is this: ZAP ZPUino Arduino Papilio - it's version 2.05, although it's based around Arduino 1.5.2.

 

If you've got that installed, you can start it up (Arduino.exe) - it's visually unchanged from the standard Arduino environment which I hope you're already familiar with.  The differences are in the menus - in the Tools menu, you will be able to select various flavours of Papilio boards.  For a Papilio Pro you will have choices such as selecting one with VGA support built in for either a Logic Start or Arcade Megawing.  If you have one of these add-on boards and want to try the VGA examples, pick one of those board entries from the menu.

 

Also in the Tools menu you should pick the right serial port for the board and select 'Papilio programmer' from the Programmer submenu.

 

Finally before you can send any programs to the Papilio Pro you will need to select the 'Burn Bootloader' option from the Tools menu - this sends the bitfile for the selected flavour of ZPUino to the Papilio's FLASH.

 

Once the bootloader's flashed to the board, you will be able to send Arduino programming to it using the Send toolbar button same as with a regular Arduino.

 

Hope that was what you wanted to do - if not, some more detail would be needed.

Share this post


Link to post
Share on other sites

Dear RorschachUK and Jack,

 

Thanks for your great support

 

My working environment is based on Ubuntu, I want to use ZAP IDE at Ubuntu 12

 

So i check how to  install tool chain

 

http://retroramblings.net/?page_id=637

 

After install, i download the linux version of ZAP IDE

 

It seems the linux verson is just 1.0

 

ZAP (ZPUino Arduino Papilio) IDE 2.0.5 it only have windows version?

 

Thank you

 

Kimi

Share this post


Link to post
Share on other sites

Alvie has been handling the linux versions, let me get with him tomorrow and see if we can generate the latest version for linux.

 

I believe there was mention hereabouts of a Mac OS X version too?

Share this post


Link to post
Share on other sites

There is a Mac OS X version, I have not tried it yet, but it is out there. It will not support the AVR8 soft processor since we are dependent on the data2mem tool and there is no version for the Mac. It should work just fine with ZPUino though.

 

Jack.

Share this post


Link to post
Share on other sites

Hello all,

 

anything new on ZAP IDE Linux? I tried the Linux x86 version from Alvie's site on my 64bit Ubuntu. I exchanged the rxtx lib to the 64bit Version and the IDE starts up but no serial port is found (besides this tcp port thinggy)

Any advise how to get the ZAP IDE going on a 64 bit Linux?

 

B.t.w. the windows version within wine shows up some com ports but none is found for upload finally (neither ZPUIno in SPI as Loader nor an AVR)

 

Thanks a lot

Peter

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now