niblettr

Unable to talk to Papilio Pro hrough loader version (dont know what version)

Recommended Posts

Ok, this is the first time I've messed with FPGAs

First problem, I've downloaded and installed Loader V2.4,v2.4 and v2.3 and they all when installed say they are at version 2.1???

They also all don't list the Papilio pro in the drop down menu...

 

Therfore I set it to Auto detect onboard FPGA devise and try to download the example .bit file and I get the following :-

 

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.
Using devlist.txt
readusb: Timeout readusb
terminate called after throwing an instance of 'io_exception'

 

 

FTDI drivers installed fine btw...

 

I have also tried another usb cable and USB port..

 

I'm using windows 7.

 

Any ideas?

Thanks

Share this post


Link to post
Share on other sites

Is it a case of just plugging in the board to the usb and off you go or is there a special mode you have to put the board in?

Getting started information is very scartered and not very noob friendly if I'm honest.

 

Also, under device mangager, when I plug in the board, the only thing I see happen is it add to extra com ports in the list COM6 and COM7 I assume this is normal? The reason why I meantion this is that the drivers are called gadget factory something..... So I expected to see Gadget factor something... listed as one of the devices (e.g. Android USB Devides -> My HTC ) Don't know if this info helps but though I'd put it here anyway..

 

Board version is 1.3 (so it says on the silk screen)

Share this post


Link to post
Share on other sites

Hello nibleattr,

 

This is not an error I've ever seen before... It sounds like the drivers are installed and working correctly based on what you are seeing in the device manager. There should not be any need to change the default settings for the Papilio Loader application.

 

Is there any chance that you have another FTDI device plugged in? Or could a virus application be causing problems? Could you do a reboot of the computer and see if that makes any difference?

 

I'm going to be logged into chat and can help you further with troubleshooting there if you would like.

 

Jack.

Share this post


Link to post
Share on other sites

Hi, thanks for the responce.

I actually got it going in the end.

Turns out, I plugged the board in before installing the loader together with the driver so windows installed generic FTDI drivers (which don't work)

 

I removed the drivers with an FTDI remove tool, reinstalled loader with gadget factory drivers and then plugged in the papilio pro board and the driver now shows in the device manager as a "Papilio com port" It now programs :)

 

One question, I was expecting there to be 2 papilio com ports listed instead of one in the device manager? Is this correct?

 

Thanks again.

Rob

Share this post


Link to post
Share on other sites

Rob,

 

The Papilio drivers will actually set the Channel A adapter to not show up as a COM port. The reason for that is we only use Channel A to program the FPGA using JTAG, its never used as a serial port. It is supposed to make things less confusing. :)

 

Jack.

Share this post


Link to post
Share on other sites

I have a similar issue.
Rob described that his Loader showed V2.1 and he had installed v2.4.
I have the same issue but that issue was not fully resolved.

I used to use the old "DOS" downloader/programmer to my Papilio One 500 gate.

Then I tought I should upgrade my downloader to the windows loader version v2.4 as I wanted to use my new Papilio Pro with this new fancy windows application.

Same thing here the installation file says Papilio Loader-2.4-Setup.
But when installed  the Loader top bar it says v2.1 and also in the about box v2.1.
And I cant select a Papilio Pro as a target.
I have not even installed the windows Loader v2.1? (Or maybe I have and forgot?)

 

Is the installation program detecting what driver I have on my system and install Loader versions variants depending on that?
Also when I install the application the installation wizard says that v2.4 will be installed.

Any suggestions?
Best Regards

Niklas


 

Share this post


Link to post
Share on other sites

AFAIK the GUI never had the versions updated, and it will auto detect the Papilio Pro correctly you don't need to select it.

true, mine does not show the pro in the pull down menu but programs just fine when set to autodetect. Just make sure its using the right driver under control panel.

 

 

 

humm (it says i can't use an image extension on this community...)

try this >> https://docs.google.com/file/d/0Bw8i0o4iJQnBSG9sb1FVSHVlbXc/edit?usp=sharing

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now