skyseb

Problem With ISE

Recommended Posts

Hello,

 

I have a problem with ISE- Xilinx, when i start "Generation Programming File" , ISE print this error message:

"Started : "Map".

Running map...
Command Line: map -intstyle ise -p xc3s500e-vq100-4 -cm area -ir off -pr off -c 100 -o Papilio_AVR8_map.ncd Papilio_AVR8.ngd Papilio_AVR8.pcf
Can't open perl script "f:\Perl\bin\map": No such file or directory

Process "Map" failed"

 

have you any idea about this error?

Thanks.

Share this post


Link to post
Share on other sites

That is pretty weird, I've never seen anything like that before.

 

My guess is that you have something in your path before the xilinx path statement that is causing the xilinx tools to look in the f:\perl\bin directory for the map.exe tool. Maybe try to look at your path and either remove the perl directory or move it to the end.

 

This is just a guess...

 

Jack.

Share this post


Link to post
Share on other sites

Looks like it, indeed, and looks like ISE itself is not in the path. But, the synthesis ran fine....

So I guess there's a "map" exec somewhere that tries to call some perl "map". In perl, 'map' is a internal method.... does not make much sense.

 

Care to check what you have on your PATH settings ?

 

Alvie

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now