tuxadecimal

Problems with ISE Source Wizard

Recommended Posts

Hi, I just bought a Papilio One - 500K. While waiting for it to arrive I was playing around with the ISE Software and I was trying to follow the DCM tutorial but was unable to use the ISE IP Wizard. Here are my project settings:

post-36470-0-34284000-1356804511_thumb.j

When I try and go into the soure wizard and add the DCM it says it's not compatible with my part:

post-36470-0-67283600-1356804558_thumb.j

But it is:

post-36470-0-06571100-1356805634.jpg

In fact, I can't add any IP to it. Everything everywhere is grayed out. If I click on "Only IP compatible with chosen part" I get nothing:

post-36470-0-73975200-1356804747_thumb.j

Can someone show me what I am missing? Thanks very much in advance for any assistance!

Share this post


Link to post
Share on other sites

That is very odd... are you sure that you have installed the "WebPack" option during the installer, and that you have got a valid license file?

It might pay to run the Xilinx License Manager tool and check....

Share this post


Link to post
Share on other sites

Hi Tuxadecimal,

Not sure if this is your problem, but I found out the very latest Webpack ISE version 14.4 is no longer compatible with the Spartan 3E part used in the Papilio One (at least for IP cores). This version was only released very recently. However, the good news is the older 14.3 version should still be available (only another 6GB download away...).

I recently tried to upgrade to 14.4 (in the hopes it would help with the 14.3 BMM block ram mapping tool crashing for me) and found out about this compatibility issue out the hard way (with basically the symptoms you describe). I found I have to keep using 14.3 for the Papilio One.

-Xark

P.S. From reading the notes 14.4 *should* be OK with Papilio Pro Spartan 6, but I still had problems with IP cores (error message when trying to get a list if IP cores, so I suspect a bug). Sticking with 14.3 for Spartan 6 too for the time being. :-)

Share this post


Link to post
Share on other sites

Thank you for your help! My license was fine, tried that first but the problem was with the 14.4 version of ISE. 14.3 fixes the problem. I appreciate the suggestion because I was going to uninstall and reinstall 14.4 thinking that might be my problem, considering I hadn't used any previous version it would not have occurred to me that it could be my problem. Thanks again!

Share this post


Link to post
Share on other sites

Yes, I gather there is a precedent for Xilinx to discontinue older products in newer tool revisions.  However, they should keep the ISE 14.3 download available for an extended period.

 

It would probably be a good plan to add a note about this issue to the Papilio download page (a 6GB download is a terrible thing to waste). :-)

 

I am curious if anybody else has tried 14.4 ISE for Spartan 6 (as used in Papilio Pro/Plus) with success?

 

-Xark

Share this post


Link to post
Share on other sites

I believe xilinx has archived all the older versions of ISE in their website. you can choose to download the older version. sometimes it's good to read the release notes of a particular version before you decide to download it :)

Share this post


Link to post
Share on other sites

Is it possible to run two version of this software on the same computer?, to get the latest for spartan 6, and still be able to use the spartan 3?

If not, I guesss an VM is coming up... 

Share this post


Link to post
Share on other sites

Here is a solution to this emailed to me by Gary Ashton-Jones:

 

"I found a note on the Net to do a full install of ISE 14.4 not a WebPack install (but only acquire a WebPack licence) and the IP will be installed. Apparently a bug.

 

So I deleted the Xilinx folder and re-install and I can find all the IP now."

Share this post


Link to post
Share on other sites

Thanks Hamster,

 

I tried that and indeed, now Spartan 6 IP is working nicely for me with ISE 14.4 (and co-exists nicely with ISE 14.3 for Spartan 3E use).

 

Part of me is just a tiny bit sad that I probably won't even miss those gigabytes that are wasted on my hard drive. :-)

 

-Xark

Share this post


Link to post
Share on other sites

Hello,

 

Another little update for others finding this thread.  I looked into the 14.3 vs 14.4 ISE issue again today and found that Xilinx now has a proper "device pack" upgrade for ISE 14.4 available here: http://www.xilinx.co...nload/index.htm

 

After installing the update, I no longer have problems any problems using 14.4 with Spartan 3E IP cores and I think this also addresses the issue forcing you to do a "full install" for Spartan 6 IP cores (that Hamster mentioned).

 

Apparently the removal of 3E IP cores in 14.4 was "accidental" - i.e. a bug (which is nice to know for Papilio One owners).

 

- Xark

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now