ben

TV output : audio ?

Recommended Posts

Hi all,

working on a Sega Master System "emulator", I have trouble with the audio interface of the TV.

For the video, I use a 6 bit DAC made with a R-2R ladder: after much effort with the logic part, I managed to get the TV to display my composite PAL signal with decent colors -- the electrical interface never was an issue.

But I still can't get the audio part, supposedly much easier, to work correctly...  I use a delta-sigma DAC: a single wire outputs alternatively 0 or 3.3V. The plan was to add a small low-pass filter, and plus it to the audio RCA.  Whatever I tried, I need to put the volume to the maximum  to hear the music on the TV.

For the record, it works fine with earphones: it's actually too loud.

I found reference on the video electrical interface (impedance of 75 ohms), but nothing on the audio. Is it 75 ohms too ? Do I really need an amplifier ? (I tried with an op-amp, but I lacked a symmetrical power generator)

Could anyone familiar with audio electronics give me help ? I'd like to keep things simple, building on the power lines of  the Papilio (0V, +2.5V, +3.3V, +5V)

Thanks,

Ben

Share this post


Link to post
Share on other sites

Ben,

I've got an audio Wing that works well, it outputs loud and clear through an amplified speaker system.

Send me an email or PM with your address and I will ship out some Arcade Wings and one of the C/RAM Wings that I recently built up.

Jack.

Share this post


Link to post
Share on other sites

Oh, BTW,

The reference page for the Audio Wing is here. There is a PDF schematic there as well.

One trick you can try is changing the output current of the audio pins in the ucf file. I think the default is to use 12mA and you can set it to 24mA or lower if you like.

Also, how many bits are you using for the DAC? Are you using a clock to drive the DAC that is much higher than the system clock?

Jack.

Share this post


Link to post
Share on other sites

Actually, it works. But not through the SCART -- I must have made a mistake when I wired it.

I just plugged the DAC output to the audio TV input : quality might be better with a low pass filter but, as the DAC is 6 bit and 8Mhz, the lowest artefact frequency is 8/64=125 kHz, so I guess it's not worth the trouble. Plus, I'm aiming at a vintage feel, so quality is not my main target !

I'll post the schematics for my TV output wing, with the code for the audio/video encoder (for PAL, but NTSC should be easy from there)

Thanks for your answers !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now