Search the Community

Showing results for tags 'Zap IDE'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • GadgetBox Universal IoT Hardware
    • GadgetBox General Discussion
  • Papilio Platform
    • Papilio General Discussion
    • Papilio Pro
    • Papilio One
    • Papilio DUO
    • Papilio Wings
    • DesignLab IDE
    • DesignLab Libraries
    • RetroCade Synth
    • Papilio Arcade
    • Papilio Loader Application
    • Papilio Logic Sniffer
    • Retired
  • Electronics
    • Modules
  • Soft Processors
    • ZPUino
    • J1 Forth
    • AVR8 Soft Processor
  • Community
    • Gadget Factory
    • Documentation
    • FPGA Discussions
    • Community Projects
    • Pipistrello
  • Open Bench
    • Open Bench Logic Sniffer at Dangerous Prototypes
    • OpenBench Logic Sniffer at Gadget Factory
  • Gadget Factory Internal Category

Categories

  • Papilio Platform
    • Papilio One
    • Papilio Plus
    • Papilio Wings
    • LogicStart MegaWing
    • ZPUino
    • Papilio Pro
  • Papilio Arcade
  • RetroCade Synth
  • Logic Sniffer
  • FPGAs
  • DesignLab
    • Example Projects
    • Libraries

Categories

  • Papilio FPGA
    • Papilio UCF (User Constraint) Files
    • Papilio Bit Files
  • Papilio Arcade
  • RetroCade Synth
  • General
  • Beta (Test) Releases
  • Books

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 2 results

  1. OhmSweetOhm

    Windows 8.1 (lots of Problems)

    I got my Papilio One 250k and wanted to try out the soft processor AVR8. I finally got it working, but on my way it ran into a few problems. The problems i encoutered: To install the Papilio loader properly on Windows 8 or Windows 8.1 i had to disable the driver signature verification. Then the upload of the bit and bmm file for the AVR8 worked fine. After that i wanted to upload a hex file. I tried the modyfied Arduino IDE but it doesn't worked. I had the same problem as: Thxe in April, he posted a solution for this problem:http://forum.gadgetfactory.net/index.php?/topic/1956-sync-with-child-error/ I had to alter the gwak command: $(GAWK) ' BEGIN{FS=" ";} { $1= ""; print $0 > "out.mem" } ' tmp.memand i downloaded a new mysys-1.0.dll, msys-1.0-vista64.zip from: http://www.madwizard.org/electronics/articles/winavrvista It worked for me, i could use the modyfied Arduino IDE to write and upload to the Papilio, also with a custom core. To write my custom core permanetly to the SPI flash I had to modyfie the makefile and the boards.txt files: http://forum.gadgetfactory.net/index.php?/topic/1199-burn-spi-flash-directly-from-arduino-ide-for-custom-core-designs/ worked like a charm. ##############################################################papilio_Custom250burn.name=Gadget Factory Papilio Custom 250K Board (Burn)papilio_Custom250burn.upload.tool=papiliopapilio_Custom250burn.upload.protocol=sam-bapapilio_Custom250burn.upload.use_1200bps_touch=truepapilio_Custom250burn.upload.wait_for_upload_port=falsepapilio_Custom250burn.upload.native_usb=falsepapilio_Custom250burn.upload.using=papilio_Custom250burnpapilio_Custom250burn.upload.maximum_size=16384papilio_Custom250burn.build.mcu=atmega103papilio_Custom250burn.build.f_cpu=16000000Lpapilio_Custom250burn.build.core=arduino##############################################################After all that i wanted to use Atmel Studio 6 to programm my c code. But it has no support for the ATmega103, i thought. I tried the makefile from the Arduino IDE but I couldn't get it to work. I found a solution for that, but I'm not entirely sure if all the periphials will worke: #define F_CPU 16000000#define __AVR_ATmega103__#include <avr/io.h>#include <util/delay.h>int main(void){ DDRA = 0xFF; PORTA = 0x00; while(1) { PORTA = PORTA + 1; }}It compiled with no error. So I wanted to use the Papilio loader to upload the bit, bmm, and the hex file to the 250k. I got an error from the data2mem application. I simply replaced the data2mem.exe from the loader install directory with the data2mem.exe from the tool directory of the zap IDE. Finally it compiled, and uploaded it to the Papilio and with a logic analyzer I could verify that it counts at PORTA. I'm not shure if I made any mistakes that caused all of that but I got it working! I hope this is somewhat helpfull.
  2. Is there documentation that answers these questions? How do you edit, load, use schematics with the zap ide? Are schematics modifiable or can you only plug and play a schematic? Can you connect multiple schematics to the fpga and run he at the same time? Can you program each schematic's behavior as a function of the immediate state of any inputs to the system?