Benjamin Santiago

Members
  • Content count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Benjamin Santiago

  • Rank
    Newbie
  1. Benjamin Santiago

    Issue with OR and "floating" values?

    Hi I am currently working through Mike Fields'/hamsternz's pdf and have an encountered an issue. I'm up to the section about using buses (this is chapter 8). I do not have the Logic Start Megawing so I'm using LED's. I'm confident I hooked everything up correctly (I experienced something similar to what I will describe with the LED/button wing). So when I simply assign the switches to LEDs, or change the the assignments with the concatenation operator everything is fine. However, when I use only the OR operator, I sometimes get some of the LED's turning on in ways that are not correct and not predictable (ie when I let go, multiple LED's turn on). The final "problem" in chapter 8 is to take the 8 LEDs and 8 switches and make it such that the first 4 LED's show the result of OR-ing switches 0-3 with switches 4-7, and the other 4 LEDs show the result of AND-ing switches 0-3 with switches 4-7. AND behaves predictably but OR does not and I'm not really sure how to fix it. The closest I can get is to set the power line to 2.5V that just reduces the amount of "errors". I tried different resistors, different resistor values, switching around testing all switches and LEDs. I also tried to add the " | PULLDOWN" to the switches in the constraints file. Not sure what else I should do or if I'm missing something thanks! Ben