lofatt

Members
  • Content count

    4
  • Joined

  • Last visited

Everything posted by lofatt

  1. I want to use uncompressed .wav files to add sounds to my game. There aren't any audio examples in Designlab besides the Modplayer, SID, and YM2149. All of which sound like they are hard to convert .wav format to. I'm using the Modplayer now, but want to use the .wav sounds I have. What is the best and/or easiest way to achieve this hardware wise?? I'll load the wavfiles from my microSD-wing like the .mod files. It's a retro-style game so high-quality sound isnt important. I'm thinking uncompressed 8-bit, 8khz .wav audio would be ok, then I wouldnt need a codec, and probably easier to clock than 44.1khz or 22.050khz. Can I use the Audio Passthrough to the AUDIO_zpuino_sa_audiomixer and reclock it, or use delta-sigma dac and reclock? Any advise would be greatly appreciated! Thanks
  2. I cant figure out how to breakout the video signals from the vga adapter symbol/busline to be able to connect them to papilio pro pins. I dont have a megawing, but proto'd a board using the resistor ladder as done on the megawing boards. I want to use the Ch/Cl pins(C1-14) on the papilio pro so I can leave the A and B side open for my comms and switches. 4red,4green,4blue, Horiz and Vert synchs. Is there a tutiorial someone can point me to for this or some advise? Thanks. I'm adding a pic of my board to the post, I made it from the resistor ladder schematic shown on arcade megawing page.
  3. I have watched several of Jacks videos and followed them to a t with no good results when synthesizing or generating a program file in ISE designsuite14.7. The last one I attempted was Creating a new ZPUino SOC project. I did save as a new project to be able to modify read only files. ISE comes up with several errors including bram errors and wont finish creating the bitfile. I have tried editing other designlab example projects with the same type results. For instance I have the vga8 wing and papilio pro spartan6lx9, edited that working project with ISE, did nothing to it and tried to synthesize and create program file, same type errors. These were all working projects that I loaded to the papilio pro and ran with designlab and Zap2.3, with exception of the Creating a new ZPUino SOC project. I am trying to create a zpuino with vga and 2 uart/com ports. I dont know if i'm doing something wrong or the newer ISE design suite14.7 doesnt want to work these older Zap and designlab programs. Maybe I missed a step or need setup something in ISE? Thanks for any help..
  4. I Got everything to work by uninstalling designlab, ZAP, and ISE designsuite14.7, then reinstalling only Designlab 1.0.8 and ISE designsuite14.7. Opened an example and saved to a new folder in Designlab for newprojects, edited and generated program file no problem. I must have made a newb mistake when I first installed programs or something was configured wrong. Now ISE sees the symbol libraries from Designlab too. Yay! Time to continue learning and using Jacks great tutorials.