1iDev

Members
  • Content count

    3
  • Joined

  • Last visited

Community Reputation

0 Neutral

About 1iDev

  • Rank
    Newbie

Profile Information

  • Gender
    Not Telling
  1. Jack, I did write to SPI Flash. So I downloaded your bit file, loaded it and tried to load the sketch and still the same result. JTAG chainpos: 0 Device IDCODE = 0x41c22093 Desc: XC3S500EUsing devlist.txtJTAG chainpos: 0 Device IDCODE = 0x41c22093 Desc: XC3S500E Uploading "C:\Program Files (x86)\Gadget Factory\Papilio Loader\programmer\bscan_spi_xc3s500e.bit". Done.Programming time 183.0 ms Programming External Flash Memory with "C:\Downloads\papilio_soc_base-working.bit".Found SST Flash (Pages=2048, Page Size=264 bytes, 4325376 bits).Erasing :OkVerifying :.....PassProgramming :..............Finished ProgrammingOkVerifying :.....PassUsing devlist.txtDone.SPI execution time 5948.3 msUSB transactions: Write 2881 read 2164 retries 0JTAG chainpos: 0 Device IDCODE = 0x41c22093 Desc: XC3S500E Using devlist.txtISC_Done = 0ISC_Enabled = 0House Cleaning = 1DONE = 0
  2. Jack, No worries, that compiled... I have tried several things here, and I ultimately think this is a problem with the zpuino ide... I downloaded the zpuino bit file and loaded it to the board, and tried uploading a blink test and same issue the ide just hangs. Reading some other posts I even tried arduino-0102-windows same issue. this is all that happens The settings I have: Board=ZPUino on PapilioOne(500) Com=Com7(USB Serial Converter A)
  3. I have downloaded the SoC project, was able to modify the schematic and add uart to wb slot 5. Created a bit file loaded it to the Papilio One(500). Using Zpuino Arduino 0100-Z-windows created simple blink test sketch. Select the correct com port, Board=ZPUnio on Papilio One(500), click on upload. Get initial message: Binary sketch size: 732 bytes (of a 27648 byte maximum). And Hangs.... let it sit there for 15 minutes. So I take a step back and started to replicate the example here and I pull the header files from github and I get these errors when verifying the sketch SoCLogicWingTest.cpp:120: warning: 'void test()' defined but not usedSoCLogicWingTest.cpp:128: warning: 'void hello()' defined but not usedSoCLogicWingTest.o(.text._Z5setupv+0x4a): In function `.L17':: undefined reference to `VGAZX'SoCLogicWingTest.o(.text._Z5setupv+0x50): In function `.L9':: undefined reference to `VGAZX_class::begin(unsigned int)'SoCLogicWingTest.o(.text._Z5setupv+0xa2): In function `.L19':: undefined reference to `pt_init_smallfs(SmallFSFile&)'SoCLogicWingTest.o(.text._Z5setupv+0xea): In function `.L19':: undefined reference to `VGAZX_class::loadscr(SmallFSFile&)'SoCLogicWingTest.o(.text._Z5setupv+0x11b): In function `.L19':: undefined reference to `pt_init_smallfs(SmallFSFile&)'SoCLogicWingTest.o(.text._Z4loopv+0x2b): In function `loop()':: undefined reference to `pt_render'SoCLogicWingTest.o(.text._Z4loopv+0x167): In function `.L63':: undefined reference to `pt_render'collect2: ld returned 1 exit statusmake: *** [soCLogicWingTest.elf] Error 1C:\projects\Tools\arduino-0100-Z-windows\arduino-0100-Z\hardware\tools\zpu\bin\make returned 2 Any thoughts?