ready2go

Errors when starting DesignLab 1.0.8 linux64 on Ubuntu 16.04 LTS

7 posts in this topic

Hello,

I have brushed the dust off my Papilio Pro, and am trying to get the  DesignLab IDE running on Ubuntu 16.05 LTS.

  • I have installed and licensed Xilinx ISE 14.7_1015_1 as WebPack
  • ISE seems to run fine...
  • I installed the default-JRE as
    sudo apt-get install default-jre
    
    java -version
    openjdk version "9-internal"
    OpenJDK Runtime Environment (build 9-internal+0-2016-04-14-195246.buildd.src)
    OpenJDK 64-Bit Server VM (build 9-internal+0-2016-04-14-195246.buildd.src, mixed mode)

     

  • I downloaded and set-up DesignLab as DesignLab-1.0.8-linux64.tgz, by running ubuntu-setup.sh

I get errors when starting DesignLab:

1. JRE Version Problem

$ ./DesignLab 
Exception in thread "main" java.lang.ExceptionInInitializerError
	at processing.app.Preferences.init(Preferences.java:286)
	at processing.app.Base.main(Base.java:168)
Caused by: java.lang.NumberFormatException: For input string: "9-i"
	at jdk.internal.math.FloatingDecimal.readJavaFormatString(java.base@9-internal/FloatingDecimal.java:2054)
	at jdk.internal.math.FloatingDecimal.parseFloat(java.base@9-internal/FloatingDecimal.java:122)
	at java.lang.Float.parseFloat(java.base@9-internal/Float.java:451)
	at java.lang.Float.<init>(java.base@9-internal/Float.java:532)
	at processing.core.PApplet.<clinit>(Unknown Source)
	... 2 more

Problem seems to be that the Processing IDE base being used searches for a single digit version JRE

http://askubuntu.com/questions/832486/errors-when-trying-to-run-arduino

2. Missing libraries

I used nix-shell to create an environment with a different JRE, I just used the default jre. I'm not claiming this is anything other than a blind hack. I don't do java.

$ java -version
openjdk version "1.8.0_121"
OpenJDK Runtime Environment (build 1.8.0_121-13)
OpenJDK 64-Bit Server VM (build 25.121-b13, mixed mode)

When I run ./DesignLab, the java. errors disappear, but I then get GTK errors:

$ ./DesignLab 
Gtk-Message: Failed to load module "overlay-scrollbar"
Gtk-Message: Failed to load module "canberra-gtk-module"

I've tried all sorts of stuff - loaded every variant of GTK I can find.. I believe it is an interaction between the 'skin' of the java app and the jre. 

Can anyone offer a solution?

Or.. Can anyone tell me what jre the original Processing IDE was delivered with/ or is compatible with?

 

Cheers,

-- Peter G

Share this post


Link to post
Share on other sites

Hello Peter,

Any luck yet on getting it to run? Java 7 should be the safest version to use...

Jack.

Share this post


Link to post
Share on other sites

Hi Jack,

All working - successfully loaded and ran the DesignLab quickstart project, following the getting started video.

  • I installed the Oracle JAva-7 jre - following these instructions, including setting $JAVA_HOME 
  • I reinstalled the usb/serial port libraries:
    sudo aptitude reinstall libftdi-dev
    .
  • Then I checked the ports were mapped properly: 
$ dmesg | grep tty
[    0.000000] console [tty0] enabled
[ 2930.811615] usb 6-2: FTDI USB Serial Device converter now attached to ttyUSB0
[ 2930.813609] usb 6-2: FTDI USB Serial Device converter now attached to ttyUSB1
[ 3233.928989] ftdi_sio ttyUSB0: FTDI USB Serial Device converter now disconnected from ttyUSB0
  • Followed the instructions in the video

Pretty simple really - once I knew what to do :)

 

Cheers,

--Peter G

 

Share this post


Link to post
Share on other sites

I just downloaded and tested Ubuntu 16.04 and 16.10 images. I followed this guide and the only difference was that the install script is called ubuntu-setup.sh now instead of ftdi-user. I also installed the default-jre using apt-get which installed OpenJDK 8 and all went smoothly...

Glad you got your working. :)

Jack.

Share this post


Link to post
Share on other sites

Hi Jack,

 

As an experiment, I tried a different java configuration, using:

sudo update-alternatives --config java

to set my JRE to java-8-openjdk-amd64, and set JAVA_HOME. Everything aso worked properly there. 

I believe my problems were because my system did not have JAVA_HOME set by default. Because of this many java libraries were not found, causing all sorts of errors which looked in google like particular libraries were missing.

So, maybe as part of the guide to setting up, ask people to check their jre/jdk is properly installed - using this link (or something more generic) as a guide:

https://www.atlantic.net/community/howto/install-java-jre-jdk-on-ubuntu-16-04/

 

--Peter G

Share this post


Link to post
Share on other sites

It's weird though, I brought up a fresh OS install using vagrant to pull down an untouched VM image for Ubuntu 16.04 and 16.10 and all I had to do was an "sudo apt-get install default-jre" and run the ubuntu-install.sh file and it worked perfectly. No need to set JAVA_HOME at all. Did you maybe install the JDK instead of the JRE? Maybe that would explain the difference...

Jack.

Share this post


Link to post
Share on other sites

Hi Jack,

That's a good result then. Unfortunately my workstation has more history than a fresh vagrant image. There is constant frustration trying to run development environments in a reproducible environment.

I have been trying to use nix-shell manage the problem recently - works nicely with Stack/Haskell. I was concerned about having problems with the USB drivers if I ran DesignLab in a virtual environment, seemed pretty heavyweight to include ISE as well. Configuring interacting docker instances seems to be difficult and ever-changing. I am considering trying out Ubuntu's Snaps as a solution. There is quite a nice Smalltalk implementation that I'd like to look at, but it is extremely hard for anyone but the sole developer to get the environment running.

Anyway - my lack of java config skill was to blame. DesignLab seems easy to configure - amazingly interesting. Well done!

Cheers,

--Peter G

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now