Search the Community: Showing results for tags 'wii nunchuck'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • GadgetBox Universal IoT Hardware
    • GadgetBox General Discussion
  • Papilio Platform
    • Papilio General Discussion
    • Papilio Pro
    • Papilio One
    • Papilio DUO
    • Papilio Wings
    • DesignLab IDE
    • DesignLab Libraries
    • RetroCade Synth
    • Papilio Arcade
    • Papilio Loader Application
    • Papilio Logic Sniffer
    • Retired
  • Electronics
    • Modules
  • Soft Processors
    • ZPUino
    • J1 Forth
    • AVR8 Soft Processor
  • Community
    • Gadget Factory
    • Documentation
    • FPGA Discussions
    • Community Projects
    • Pipistrello
  • Open Bench
    • Open Bench Logic Sniffer at Dangerous Prototypes
    • OpenBench Logic Sniffer at Gadget Factory
  • Gadget Factory Internal Category

Categories

  • Papilio Platform
    • Papilio One
    • Papilio Plus
    • Papilio Wings
    • LogicStart MegaWing
    • ZPUino
    • Papilio Pro
  • Papilio Arcade
  • RetroCade Synth
  • Logic Sniffer
  • FPGAs
  • DesignLab
    • Example Projects
    • Libraries

Categories

  • Papilio FPGA
    • Papilio UCF (User Constraint) Files
    • Papilio Bit Files
  • Papilio Arcade
  • RetroCade Synth
  • General
  • Beta (Test) Releases
  • Books

Found 1 result

  1. I've purchased a couple of Wii Wings and Wii Nunchucks from gadgetfactory.net and I'm having no success getting them working with my Papilio Pro and the WiiChuck example in DesignLab 1.0.8 I've connected the Wii wing to slot AL on the Papilio Pro and loaded the circuit and sketch for it, but the only output I get in the serial monitor is: Starting I2C at slot 9, instance 1, base register 0x0c800000 0 Chuck: 255 255 buttons 0 0 Chuck: 255 255 buttons 0 0 Chuck: 255 255 buttons 0 0 Chuck: 255 255 buttons 0 0 Chuck: 255 255 buttons 0 0 ... Pressing either button or moving the joystick does not cause any change in the output values. As a test I powered the Papilio Pro up without the Wii wing connected and after starting the serial monitor pressed the reset button on the Papilip Pro and get: Starting I2C at slot 9, instance 1, base register 0x0c800000 0 with no further output, as expected. I've tried both Wii wings and both nunchucks that I purchased and both give the same result. As another test I wired the Wii wing with the nunchuck connected to an Arduino Uno and used the library and example at this site: http://todbot.com/blog/2008/02/18/wiichuck-wii-nunchuck-adapter-available/ and received the same output values via the serial monitor as when connected to the Papilio Pro. I've got the nunchucks connected to the Wii wing so that the nunchuck's pinout matches the silkscreen (The 'indented' side of the nunchuck connector that has no middle pin facing up) and I've verified connectivity from the pin on the wing to the pin of the nunchuck via a DMM. Any ideas on what may be going on? I wouldn't think that I managed to get two bad sets of Wii wings and nunchucks so I'm at a bit of a loss as to what the issue could be. Best regards, Anthony