Search the Community: Showing results for tags 'ubuntu 16.04'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • GadgetBox Universal IoT Hardware
    • GadgetBox General Discussion
  • Papilio Platform
    • Papilio General Discussion
    • Papilio Pro
    • Papilio One
    • Papilio DUO
    • Papilio Wings
    • DesignLab IDE
    • DesignLab Libraries
    • RetroCade Synth
    • Papilio Arcade
    • Papilio Loader Application
    • Papilio Logic Sniffer
    • Retired
  • Electronics
    • Modules
  • Soft Processors
    • ZPUino
    • J1 Forth
    • AVR8 Soft Processor
  • Community
    • Gadget Factory
    • Documentation
    • FPGA Discussions
    • Community Projects
    • Pipistrello
  • Open Bench
    • Open Bench Logic Sniffer at Dangerous Prototypes
    • OpenBench Logic Sniffer at Gadget Factory
  • Gadget Factory Internal Category

Categories

  • Papilio Platform
    • Papilio One
    • Papilio Plus
    • Papilio Wings
    • LogicStart MegaWing
    • ZPUino
    • Papilio Pro
  • Papilio Arcade
  • RetroCade Synth
  • Logic Sniffer
  • FPGAs
  • DesignLab
    • Example Projects
    • Libraries

Categories

  • Papilio FPGA
    • Papilio UCF (User Constraint) Files
    • Papilio Bit Files
  • Papilio Arcade
  • RetroCade Synth
  • General
  • Beta (Test) Releases
  • Books

Found 1 result

  1. Hello, I have brushed the dust off my Papilio Pro, and am trying to get the DesignLab IDE running on Ubuntu 16.05 LTS. I have installed and licensed Xilinx ISE 14.7_1015_1 as WebPack ISE seems to run fine... I installed the default-JRE as sudo apt-get install default-jre java -version openjdk version "9-internal" OpenJDK Runtime Environment (build 9-internal+0-2016-04-14-195246.buildd.src) OpenJDK 64-Bit Server VM (build 9-internal+0-2016-04-14-195246.buildd.src, mixed mode) I downloaded and set-up DesignLab as DesignLab-1.0.8-linux64.tgz, by running ubuntu-setup.sh I get errors when starting DesignLab: 1. JRE Version Problem $ ./DesignLab Exception in thread "main" java.lang.ExceptionInInitializerError at processing.app.Preferences.init(Preferences.java:286) at processing.app.Base.main(Base.java:168) Caused by: java.lang.NumberFormatException: For input string: "9-i" at jdk.internal.math.FloatingDecimal.readJavaFormatString(java.base@9-internal/FloatingDecimal.java:2054) at jdk.internal.math.FloatingDecimal.parseFloat(java.base@9-internal/FloatingDecimal.java:122) at java.lang.Float.parseFloat(java.base@9-internal/Float.java:451) at java.lang.Float.<init>(java.base@9-internal/Float.java:532) at processing.core.PApplet.<clinit>(Unknown Source) ... 2 more Problem seems to be that the Processing IDE base being used searches for a single digit version JRE http://askubuntu.com/questions/832486/errors-when-trying-to-run-arduino 2. Missing libraries I used nix-shell to create an environment with a different JRE, I just used the default jre. I'm not claiming this is anything other than a blind hack. I don't do java. $ java -version openjdk version "1.8.0_121" OpenJDK Runtime Environment (build 1.8.0_121-13) OpenJDK 64-Bit Server VM (build 25.121-b13, mixed mode) When I run ./DesignLab, the java. errors disappear, but I then get GTK errors: $ ./DesignLab Gtk-Message: Failed to load module "overlay-scrollbar" Gtk-Message: Failed to load module "canberra-gtk-module" I've tried all sorts of stuff - loaded every variant of GTK I can find.. I believe it is an interaction between the 'skin' of the java app and the jre. Can anyone offer a solution? Or.. Can anyone tell me what jre the original Processing IDE was delivered with/ or is compatible with? Cheers, -- Peter G