Search the Community: Showing results for tags 'Ethernet'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • GadgetBox Universal IoT Hardware
    • GadgetBox General Discussion
  • Papilio Platform
    • Papilio General Discussion
    • Papilio Pro
    • Papilio One
    • Papilio DUO
    • Papilio Wings
    • DesignLab IDE
    • DesignLab Libraries
    • RetroCade Synth
    • Papilio Arcade
    • Papilio Loader Application
    • Papilio Logic Sniffer
    • Retired
  • Electronics
    • Modules
  • Soft Processors
    • ZPUino
    • J1 Forth
    • AVR8 Soft Processor
  • Community
    • Gadget Factory
    • Documentation
    • FPGA Discussions
    • Community Projects
    • Pipistrello
  • Open Bench
    • Open Bench Logic Sniffer at Dangerous Prototypes
    • OpenBench Logic Sniffer at Gadget Factory
  • Gadget Factory Internal Category

Categories

  • Papilio Platform
    • Papilio One
    • Papilio Plus
    • Papilio Wings
    • LogicStart MegaWing
    • ZPUino
    • Papilio Pro
  • Papilio Arcade
  • RetroCade Synth
  • Logic Sniffer
  • FPGAs
  • DesignLab
    • Example Projects
    • Libraries

Categories

  • Papilio FPGA
    • Papilio UCF (User Constraint) Files
    • Papilio Bit Files
  • Papilio Arcade
  • RetroCade Synth
  • General
  • Beta (Test) Releases
  • Books

Found 2 results

  1. Hello everybody, first i would like to say that my problem has nothing to do with the FPGA part, i'm not using any soft processor in the FPGA. I would like to connect an Arduino Ethernet Shield (with the W5100 chip) to the AVR part of my DUO. I already have an ENC28J60 card running with the UIPEthernet library, this card is also connected via SPI. BUT: For the ENC28J60 i needed to set the SPI pins to #define UIP_FORCE_SS 53 #define UIP_FORCE_SCK 52 #define UIP_FORCE_MOSI 51 #define UIP_FORCE_MISO 50 (these UIP_FORCE constants were invented by myself). This is working! But i don't understand it , because the AVR does not have these high output pin numbers ?!? The standard ethernet library for the Arduino Ethernet Shield obviously uses some other pins, but i'm unable to extract the pins from the library source code, this is all very confusing. What is NOT working: SCK 13 MISO 12 MOSI 11 SS 10 or 8 I know that i have to connect these Arduino Pins from the DUO to the ICP header at the Ethernet Shield. Well, this is all very mysterious. Maybe someone could tell me simply which Pins on the DUO are the official SPI connections? I will also try some other SPI device in the meantime. Best Regards, Christof
  2. Is there a plan to create an Ethernet wing for Papilio? Or does anyone know any breakout board for http://www.micrel.com/_PDF/Ethernet/datasheets/KSZ9021GQ.pdf or similar? Thanks Samuel