mikejohnson

Members
  • Content count

    5
  • Joined

  • Last visited

Everything posted by mikejohnson

  1. I tried that, with no luck. Same error message
  2. Hi I bought one of these DUO 2MB boards a while ago but I've just got to start playing with it. I'm failing pretty early on, and searching older posts suggests I'm not the first. The message I'm getting is: Programming to SPI Flash Using devlist.txt Invalid chain position 0, position must be less than 0 (but not less than 0). Unknown Papilio Board Using devlist.txt USB transactions: Write 2 read 1 retries 0 Invalid chain position 0, position must be less than 0 (but not less than 0). IOException: Cannot open file I have swapped cables, and tried an account with no spaces in the name. No luck. Anyone got any ideas or am I looking at a faulty board?
  3. OK, looks like it works on Linux, which is probably better for this sort of thing anyway. Thanks for your help!
  4. Thanks, I tried "Papilio DUO A" and "Papilio DUO B" but still no luck sadly. I just can't get DesignLab to talk to this board. Still, "Unknown Papilio Board". I did have a play with the Papilio loader and loaded C:\DesignLab-1.0.8\examples\Papilio_DUO_ArduinoISP\Papilio_DUO_ArduinoISP.bit - it seemed to almost work with the following output. Sorry if this isn't relevant, I'm new to this. JTAG chainpos: 0 Device IDCODE = 0x24001093 Desc: XC6SLX9 Using devlist.txt JTAG chainpos: 0 Device IDCODE = 0x24001093 Desc: XC6SLX9 Uploading "C:\Program Files (x86)\Gadget Factory\Papilio Loader\programmer\bscan_spi_xc6slx9.bit". DNA is 0x199aaccb571e1aff Done. Programming time 504.0 ms Programming External Flash Memory with "C:\DesignLab-1.0.8\examples\Papilio_DUO_ArduinoISP\Papilio_DUO_ArduinoISP.bit". Found Macronix Flash (Pages=32768, Page Size=256 bytes, 67108864 bits). Erasing : Doing Partial Erase ......Ok Verifying : ......Pass Programming : ......Ok Verifying : Using devlist.txt ......Pass Done. SPI execution time 16217.6 ms USB transactions: Write 6853 read 6684 retries 0 Using devlist.txt Response incompatible with mask xxxx01 Invalid chain position 0, position must be less than 0 (but not less than 0). ISC_Done = 1 ISC_Enabled = 1 House Cleaning = 1 DONE = 1
  5. That's a bit annoying then. It's definitely the only FTDI device connected. Must be a board problem.