Skip

Members
  • Content count

    27
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Skip

  • Rank
    Member

Profile Information

  • Gender Male
  1. Are there any command line tools or example code to setup advanced triggers? The only program I've found that supports the advanced trigger is a Windows executable which doesn't help me since I'm running Linux. Skip
  2. Thanks Jack !! That fixed all of my build issues. Sorry for all of the noise and confusion! I've learned a lot in the last couple of weeks. Skip
  3. Hi @Jack Gassett, I think I finally got it right. Give it a look and let me know what you think. Skip
  4. Hi @Jack Gassett, Opps... hold off on pulling the changes I just found a problem. I had replaced DesignLab-1.0.8/examples with the DesignLab_Example git repository. I just discovered that there's no example/libraries subdirectory in the release. Sorry about that! Skip
  5. Hi @Jack Gassett, I finished fixing all Benchy_Sump_LogicAnalyzer_Standalone targets and I've sent you a pull request. I've tested the DUO bit file built from a fresh tree with the changes. I haven't tested the other targets since I don't have hardware. For a while I didn't think the Papilio_One_500K target working because it appeared hang while routing, however it was just REALLY slow. I can understand if a smaller part takes more time to route than a larger part because it is fuller, but the 250K part routed MUCH faster! Any idea of what's happening here? Is this typical? Skip
  6. Hi @Jack Gassett, I fixed all of the issues with the Benchy_Sump_LogicAnalyzer_Standalone example for the DUO ONLY. I'll fix the other targets and then send you a pull request. I suspect other examples will have similar problems. I'm going to try to do some global search and replaces to fix the issues on all of the .xise files in the examples and then test a few. I would probably take days for my pokey machne to build all examples and targets! One of the biggest issues on Linux was that there was a .../examples/libraries/clocks AND a .../examples/libraries/Clocks. I moved all of the files from ../examples/libraries/clocks into ../examples/libraries/Clocks and then deleted ../examples/libraries/clocks. Any projects with references to the lower case clocks will now be broken on Linux, of course Windows won't care. Skip
  7. Hi @mkarlsson! I'm very new to this ... but I've been doing a LOT of reading of old posts, etc. I happy you are still around, most of the treads I've been reading here there and everywhere seem to have gone quiet a couple of year ago. I'm very impressed with all of the work everyone has put into OLS and related projects! I hadn't mentioned it, but I get garbage at 200 Mhz even without RLE. I get good data at 100 Mhz and 20 Mhz w/o RLE which are the only other clock rates I've tried so far. The Papilio DUO is the only hardware I have right now so I can't really tell if I have a client problem or a target problem. I'm going to try to port the Verilog implementation to my DUO and see how it compares. I tried using pulseview briefly, but it doesn't seem to recognize my Papilio. Skip
  8. @Jack Gassett, I just succeeded in rebuilding the Benchy_Sump_LogicAnalyzer_Standalone example, but I did run into some issues. Some issues were related to running on Linux (file system case sensitivity), some were related to references to "../../../DesignLab/build/windows/work/examples/", and some were related to an apparent reorganization of the tree structure. I forked DesignLab_Examples on github and committed my changes to the fork. I'm going to take a look at the RLE stuff and see if I can contribute a fix. Don't expect to much, I'm just learning VHDL. Skip
  9. Hi @Jack Gassett, After I copied ols.profile-papilio-duo.cfg from the DesignLab tree into the ols plugins directory I had some success using the ols-0.9.7.2 client from http://ols.lxtreme.nl as long as I leave Run Length Encoding disabled. I guess my primary question at this point is if there is any reason I need to use the ols version bundled with DesignLab? Enabling RLE corrupts the data badly. I'm using a bus I2C bus as a test, with RLE disabled the clock is a very nice and stable 350Khz. When I enable RLE it looks completely different. Skip
  10. Hi Jack, I ran the script manually and the problem appears to be a missing dependency (missing requirement [10.0] osgi.wiring.package). A full log of the run is attached. This is a pretty virgin install of Ubuntu 16.04.1 LTS, I've installed it from scratch when I got my DUO and I've only been installing Papilio related tools on it. Skip Logic_Analyzer.log
  11. Hi @Jack Gassett, I've installed DesignLab-1.0.8 and I was able to successfully run the Papilio_DUO_QuickStart example (BTW: Way cool, no installation issues at all on Ubuntu 64 bit). When I click the logic analyzer icon the bit file is downloaded successfully, but the logic analyzer never starts. No messages are displayed after the bit file is programmed. If I say "No" to "Would you like to load a Logic Analyzer..." dialog no messages are displayed either. I had installed ols-0.9.7.2 that I downloaded from http://ols.lxtreme.nl prior to installing DesignLab so I tried it and it ran (sort of). I see a 100Mhz clock on channel 1, but I can't find any configuration screens to select clocking, capture width, etc. Does the bit file loaded by DesignLab need to used with the DesignLab OLS client? This is the coolest thing I've played with in YEARS! I've already run CP/M and Pacman on the board, I can't wait to get the logic analyzer running! Skip
  12. Thanks Jack for link, I'll give it a try! Skip
  13. Hi @Jack Gassett, I've flashed the 8 channel Logic Analyzer for the Papilio DUO bit file I found in ./build/shared/tools/logicanalyzers/DUO_LX9/papilio_duo_lx9.bit successfully. I've unplugged the Papilio and plugged it back in again, but it's only enumerating as the JTAG device, I don't see the serial port. Do I assume correct that I should be plugging in the USB FPGA connector? The green LED is flashing at about a 1 Hz rate. I'm running Ubuntu 16.04.1 LTS 64 bit. lsusb shows: Skip
  14. Hi @Jack Gassett, Are the sources for the DUO version available? I'm interested in using 8/16/32 bits with my DUO and the I/O buffer wings. Skip
  15. I was so excited hearing sound for the first time I didn't try to reproduce the issue before I reported back. Later I changed SW1 to UP and I still got sound so I'm not sure what the problem was. My joystick should come today so I hope to actually play PACMAN tonight! Thanks for the amazing product and seeding a great community of helpful, knowledgeable, and friendly people! Skip