Pizus

Members
  • Content count

    13
  • Joined

  • Last visited

  • Days Won

    1

Community Reputation

2 Neutral

About Pizus

  • Rank
    Member

Profile Information

  • Gender Male
  • Location Rome
  1. Really nice case! I would be interested in getting one.
  2. HI Alvie, I tried the bit file, but Impact does not allow me to assign it to the S3E. "A BIT file describing an is about to be assigned to a device identified as an XC300S500E". Frankly, i did not undesrtand what it meant. Maybe you compiled the project with a different device target?. Bye Pizus
  3. Hello everyone, i was blowing away the dust from my S3E starter kit to play with it at home. All went fine...no smoke I mean. I programmed the ZPUino (the Alvie file zpuino-1.0-S3EEvalBoard-S3E500.bit ) but when I tried to run the demo sketch, I got an "Unknown flash type" error. It is a long time since I played with the ZPU, so maybe I am doing something silly..but at around midnight, I am not yet out of it, so I must ask for some help and go to sleep. Bye Pizus
  4. I know the pipistrello board. But ...I am not the board designer, only the section manager and I have suggested the design team to take a look at that board too.
  5. I would like to have been born in a place where houses cost 10K$ Here in Rome, a medium sized flat is at about 350K$ Anyway, I'll have to carefully check the manufacturing costs of next board (feat. a S6, an ext uC etc) that I am going to use in my job.
  6. Maybe a bit off topic, but I was noting that the de0-nano has a price tag of 79$ and uses a BGA package for the FPGA. I have no knowledge of those extremely low priced boards, but it would seem to be feasible to get a PPro with a BGA package within an acceptable price range. Of course I don't have any idea on the BOM costs. Pizus
  7. I didn't understood exactly what you are trying to do. But my 2p advice is that the stability is given by the reference oscillator (don't have the datasheet near so you have to control the jitter /phase noise characteristics). I don't know if there is a direct connection with the oscillator, but in case you should also take into account the FPGA DCM stability figure. Are you going to implent some kind of DDS inside the FPGA?
  8. This post cannot be displayed because it is in a password protected forum. Enter Password
  9. Hi, not sure but take a look at the source code vga_r <= vga_ram_data(7 downto 5); vga_g <= vga_ram_data(4 downto 2); vga_b <= vga_ram_data(1 downto 0); Maybe the Logicstart was tailored for the VGA driver. BTW the Arcade Megawing has 12b colours (4 resitors for each colour)
  10. This post cannot be displayed because it is in a password protected forum. Enter Password
  11. Hello everyone, don't know if it is of any interest but for those poor guys using windows (that don't have access to linux conversion tools) here is a small contribution to a simple image .dat generation process for ZPUino VGA with 8bit colors. 1) select your image 2) scale it to 160x120 pixels (almost any tools out there) and save in .png 3) convert the palette (Corel Photo-paint->Image->Convert to palette and select the attached .pal file) 4) save the new .png image 5) convert the .png in .raw ( Irfanview->Save As ->(raw)) 6) rename to .dat So I hope I saved you an hour or two. Bye ZPUino_VGA_8bit_palette.zip
  12. Simply downloaded from the links in the gadgetfactory site. Anyway I have not expressed myself correctly. What i was trying to do was to get the zb2 sources for ZPUino to compare the two projects that led to the two bit files reported below. . In particular I expect that there should be some diff in the ZPUino_VGA and ZPUino_vga_char_ram. zpuino-1.0-PapilioOne-S3E500-VGA160x120x8.bit zpuino-ZB2-PapilioOne-S3E500-HQVGA-8bit-ArcadeWing.bit
  13. Hello, hope not be off topic, but I was playing with papilio-plus and the arcade wing and, loading the sketches on the "zpuino-1.0-PapilioOne-S3E500-VGA160x120x8.bit" resulted in a good image but the foreground and the background of the writings are the same (cannot be read). Strangely, loading the old Z2 version resulted in the opposite behaviour: nice writings but no image. I checked the code for the IO_slot but seems to be OK. I don't know how to get the old build to compare the diff. Any hints?