1 Screenshot

About This File

Load bitstreams generated by Xilinx ISE to the Papilio One with a Java GUI or scripts.

If you need more informations about the Papilio Loader including requirements, installation and much more check the Papilio Uploader wiki page here.

Version 2.7+ includes signed drivers for Windows 8.

There are now installers for Windows, Linux, and Mac OS X.

What's New in Version 2.2   See changelog


  • Added support for Macronix 64Mb SPI Flash chips.
  • Added ability to Erase Flash chip from Explorer context menu.
  • Integrated the Java GUI and scripts option.

User Feedback

Recommended Comments

I can't get it work on OSX 10.8.5, it installs but I get the following error.


Could not access USB device 0403:6010. If this is linux then use sudo.

Share this comment

Link to comment
Share on other sites

for 64bit Linux:

don't bother running install.sh yet, first cd into "papilio-prog" directory and run these:






now you can run the linux-installer.sh in the top level directory of the Papilio Loader.


you can verify your compile worked when in the papilio-prog directory by typing ./papilio-prog and you should see this output on the command line:

No or ambiguous options specified.
Usage:./papilio-prog [-v] [-j] [-f <bitfile>] [-b <bitfile>] [-s e|v|p|a] [-c] [-C] [-r] [-A <addr>:<binfile>]
   -h                   print this help
   -v                   verbose output
   -j                   Detect JTAG chain, nothing else
   -d                   FTDI device name
   -f <bitfile>         Main bit file
   -b <bitfile>         bscan_spi bit file (enables spi access via JTAG)
   -s [e|v|p|a]         SPI Flash options: e=Erase Only, v=Verify Only,
                        p=Program Only or a=ALL (Default)
   -c                   Display current status of FPGA
   -C                   Display STAT Register of FPGA
   -r                   Trigger a reconfiguration of FPGA
   -a <addr>:<binfile>  Append binary file at addr (in hex)
   -A <addr>:<binfile>  Append binary file at addr, bit reversed

Share this comment

Link to comment
Share on other sites


I just try to find the Linux Download. When pressing Download button I get three files to select. Tried the zip. It contains a papilio loader that I can start with Linux. But it did not connect to the board.

It is not in sync with the how-to: http://blog.gadgetfactory.net/2013/09/howto-papilio-loader-gui-on-linux/

There is no linux installer, sript in the download and also not any makefile in the papilio-prog directory.

The fdti kernel drivers are loading, I can access the serial port of the board with a terminal program. 




Share this comment

Link to comment
Share on other sites

How do I get the GUI for my Papilio Duo?  When I click on the download links I get a weird error page that tells the Webmaster to contact Rackspace

Share this comment

Link to comment
Share on other sites

For anyone who just wants the command line tool for linux x64, you can grab it here.  To use it:

1. Extract to somewhere

2. Either add that somewhere to your path or create symlink in your path

Run papilio-prog as usual.

Also, I've made a small improvement.  To burn to SPI instead of having to specify -b and the name of the appropriate bscan_spi_*.bit file, you can just specify "-b auto" and it'll work it out using the same approach as the GUI tool.


papilio-prog -f yourbitfile.bit -b auto -sa -r -v


Share this comment

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now