1 Screenshot

About This File

Load bitstreams generated by Xilinx ISE to the Papilio One with a Java GUI or scripts.

If you need more informations about the Papilio Loader including requirements, installation and much more check the Papilio Uploader wiki page here.

Version 2.7+ includes signed drivers for Windows 8.

There are now installers for Windows, Linux, and Mac OS X.


What's New in Version 2.8   See changelog

Released

  • 4/1/2015 Version 2.8
  • Papilio GUI
  • -Fix for SPI Flash not programming correctly in simple mode.
  • -Change the Operations buttons to check boxes.
  • 2/24/2015 Version 2.7
  • Papilio GUI
  • -Add Board Name field so you can manually specify the board name.
  • -Added Papilio Pro, Papilio One, and Papilio DUO to Target Board dropdown.
  • -Removed .bmm and .hex fields from simple mode.
  • -Updated Icon
  • -Drivers are signed for easy install in Windows 8
  • papilio-prog
  • -Support for the Papilio DUO VID/PID
  • 1/2/2014 Version 2.6
  • Papilio GUI
  • -Changed the default behavior to write to SPI flash.
  • -Fixed problem with not doing an erase, verify, program, verify cycle.
  • -Removed old board types.
  • 10/23/2013
  • Now with Mac OS X installer!
  • 9/13/2013 Version 2.5
  • Fixed error with Java-GUI not detecting line endings in JTextBox. Everything compiles and works on Windows and Linux now.
  • Added Linux installer script.
  • 1/4/2012 Version 2.4
  • Fixes from MagnusK
  • * New cmd-line option (-d) that allows you to specify the FTDI device. This was asked for in this forum.
  • * Spartan-6 LX4 - LX45 parts are added to the built-in device list
  • * The fpga wait-code is put back
  • * The code now supports many more flash parts
  • * The number of pages in the Macronix part is corrected (32768, not 250000)
  • * Misc corrections here and there in the code
  • * The erase-before-programming is now handled by a new routine (Spi_PartialErase) that tries to be smarter about the erase.



User Feedback

Recommended Comments

I can't get it work on OSX 10.8.5, it installs but I get the following error.

 

Quickstart-Papilio_Pro_LX9-v1.5.bit 
Could not access USB device 0403:6010. If this is linux then use sudo.

Share this comment


Link to comment
Share on other sites

for 64bit Linux:

don't bother running install.sh yet, first cd into "papilio-prog" directory and run these:

 

./autogen.sh

./configure

make

 

now you can run the linux-installer.sh in the top level directory of the Papilio Loader.

 

you can verify your compile worked when in the papilio-prog directory by typing ./papilio-prog and you should see this output on the command line:

No or ambiguous options specified.
 
Usage:./papilio-prog [-v] [-j] [-f <bitfile>] [-b <bitfile>] [-s e|v|p|a] [-c] [-C] [-r] [-A <addr>:<binfile>]
   -h                   print this help
   -v                   verbose output
   -j                   Detect JTAG chain, nothing else
   -d                   FTDI device name
   -f <bitfile>         Main bit file
   -b <bitfile>         bscan_spi bit file (enables spi access via JTAG)
   -s [e|v|p|a]         SPI Flash options: e=Erase Only, v=Verify Only,
                        p=Program Only or a=ALL (Default)
   -c                   Display current status of FPGA
   -C                   Display STAT Register of FPGA
   -r                   Trigger a reconfiguration of FPGA
   -a <addr>:<binfile>  Append binary file at addr (in hex)
   -A <addr>:<binfile>  Append binary file at addr, bit reversed
 
Doug

Share this comment


Link to comment
Share on other sites

Hi,

I just try to find the Linux Download. When pressing Download button I get three files to select. Tried the zip. It contains a papilio loader that I can start with Linux. But it did not connect to the board.

It is not in sync with the how-to: http://blog.gadgetfactory.net/2013/09/howto-papilio-loader-gui-on-linux/

There is no linux installer, sript in the download and also not any makefile in the papilio-prog directory.

The fdti kernel drivers are loading, I can access the serial port of the board with a terminal program. 

 

Thomas

 

Share this comment


Link to comment
Share on other sites

How do I get the GUI for my Papilio Duo?  When I click on the download links I get a weird error page that tells the Webmaster to contact Rackspace

Share this comment


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now